How to make my app appear in the finder context menu 'open with'

I’v tried everything I can guess of, but I can’t get my app to appear in the ‘open with’ menu.

My info.plist contains this:

[code] CFBundleDocumentTypes







A corresponding file types declaration is available and works fine with open dialogs and drag and drop. I also tried to add file extensions explicitly, but that didn’t change anything at all.

To force MacOS launch services get informed about any changes I used lsregister -f -v without any errors.

Does anybody have an idea?

Thank you all!

Can you make a screenshot of the filetype in Xojo?

your imported UTI needs to set the ROLE to “editor” at the very least
then reregistering with lsregister should show it in the open with menu

in build settings, macos, then on the property inspector, choose file types
then add a role to each filetype as Norman said, at least not “none”
compile and it should be enough.

Thank you, Norman, I’ll try that, but I think I cannot publish a role that is not correct in the app store.

Thanks! Coming shortly.

I’ve done this. It’s set to ‘Viewer’.

Tried ‘editor’ as well now. No change.


The second one has just 3 extension included. In fact there are more.

I just tried inside a virtual machine with Catalina. There it works fine. Sorry for posting here.

Anyway, now I have to find out what’s wrong here. All other apps do just fine.

Thank you all!

sometimes a finder relaunch may clear things, or a restart.

Have tried this before. Now I reconstruct the launch services database.

Rebuilding the launch services database didn’t help at all. What else can be wrong?

I finally found the reason why my app didn’t show up in the finder’s context menu ‘open with’.

There are only 32 entries possible in this menu. But it looks like many apps, even those that are not really important, show up in this menu. Mine did not appear because its name is close to the alphabet’s end. After removing some apps it showed there as well.

Thank you all and have a nice WE!