How to install Xojo on Debian?

I downloaded UTM, clicked in it to download Debian Xfce, then run.

The Xojo .deb file comes from:

THIS SEEMS TO BE A x86-64 version, no other available there (xojo download web site)…

Asked chatgpt:

  1. Download the Xojo .deb file from the Xojo website (Xojo: Downloads).
  2. Open the Terminal application on your Debian system.
  3. Navigate to the directory where you downloaded the .deb file using the cd command. For example, if you downloaded the file to your Downloads folder, you can navigate there using the following command:
cd ~/Downloads
  1. Install the .deb file by running the following command:
sudo dpkg -i xojo2021r2.1.deb

Note: Replace “xojo2021r2.1.deb” with the name of the .deb file you downloaded.
5. If there are any missing dependencies, you can install them using the following command:

sudo apt-get install -f
  1. Once the installation is complete, you can launch Xojo by searching for it in the Applications menu or by running the following command in the Terminal:

That’s it! You should now have Xojo installed and ready to use on your Debian system using the .deb file.

1 Like

It looks like you are using an Arm machine and have an Intel Xojo package. I don’t think the IDE is available for Arm on Linux yet:

Ubuntu / Debian Linux | Alternate Mirror
Installer for 64-bit Debian-based Linux distributions (x86-64).

1 Like

Yes, and I wrote that some times ago…

This time, I get up.

Thank you Ian, Christophe for trying to help.

Yes, it can build applications for Arm64 linux, The IDE / Debugger etc just doesn’t run on Arm64 Linux.


I am both angry and hungry.

In the mean time, I moved an application (build with 2015r1) build for Linux. I was able to double-clic it, but it does nothing (nor ARM, not 64 Bits…)

Was it specifically set to make an Arm64 build. It needs to. Linux has no such thing as a Universal app, as macOS does. It needs to be selected on the Linux build page and then built. Either for Intel or for Arm64.

In Xojo downloads currently there’s no ARM IDE option (Windows/Linux):


No native ARM Windows or Linux:



You’re really making this harder than it needs to be.

  1. The pre-built versions of Debian that are available when you click Browse UTM Gallery are all ARM64.
  2. Xojo is built as x86_64 (Intel)
  3. The processor of the machine and the architecture of Xojo MUST match on Linux. It does not have a translation engine like Rosetta.

I should have noticed in your statement here that this was going to be a problem:

NB: MacBookPro m1 / UTM / Debian Xfce…

But I think we all assumed that you understood #3 above.

I was wrong too…

…and now my stomack is cying out loud !

Thank you for trying to help.

I’m going to suggest what I did for Intel emulation. Go get yourself a 2018 Intel Mac Mini and run parallels or VMWare there. You’ll have a much better emulation experience.

1 Like

Thank you.

Here are some instructions on how it was installed:

That’s assuming that Debian is the x86_64 version. Emile’s is ARM.

1 Like

You are correct, my instructions are for an Intel chip. The only arm computer I have is a raspberry pi, and Xojo is not designed to be installed on 64-bit arm Raspberry Pi OS.

Thanks for clarifying.

download xojo windows version and try to run it within linux with win (it runs windows programs into linux)

Stupid, obvious suggestion, but the fact that your Xojo .deb installer keeps opening in xarchiver makes me wonder if somehow your installer in not an executable file. Right-click on the file, go to properties and see if there’s a checkbox or something that says “Allow executing file as a program”. If it’s there, but unchecked, it’s not executable…hence the installer opens in xarchiver or presents the “Open with” menu.
Try these options:

  • check the box and click the close button. Double-click the installer again and see what happens.
  • Open a terminal at the installer’s location and type “chmod +x installer-filename.deb”.
    note: replace installer-filename with the actual name of the installer file, and don’t use quotes.
    Double-click the installer again and see what happens.

Again – obvious, stupid suggestion…just trying cover some bases here.
BTW: I seriously doubt it, but you might need to use “sudo chmod +x installer-filename.deb”

.deb files are not executable though. They’re a Debian Package which is installed by dpkg. It sounds like your machine has forgotten what to do with .deb files.

Right. My bad. Hasty response. :crazy_face:
Pay no attention to the man behind the curtain, Dorothy.

We had this one the other day. It’s a bug in Debian (and derivatives) that links the .deb file to an archive utility. I think we eventually came up with an answer for it. I can’t remember what it was though.