How to install MBS plug-ins for XOJO on debian distro

Can’t find the folder to put the MBS plugins in… running ubuntu 14.04

On Mint, the path to Xojo is


Inside is the Plugins folder.

Chances are it is the same under Ubuntu.

Otherwise look at the Xojo executable shortcut properties.

Did you get it working?

Oh man, its “the” Christian Schmitz. My friend, your curl plugin saved my project. Thank you. I’m about to try it now.

Yessir, that was the correct location, thank you Michael, this is definitely the most helpful forum I’ve ever been apart of. I hope to be the one answering questions soon :slight_smile:

Welcome. Have fun with the plugins!

Ok so… no I have the plugins in the right place… but I’m getting an error for
CURLSMBS as it not existing…

you can check them this way:

  • make copy of CURL plugin xojo_plugin file.
  • rename it to .zip file extension.
  • unpack the plugin archive.
  • pick the CURLS plugin file from Linux folder inside archive.
  • run ldd command in terminal with this library file. e.g. ldd

the list shows like this:

[quote]cs@ubuntu10-32:~$ ldd => (0x0023a000) => /lib/tls/i686/cmov/ (0x00cf7000) => /lib/tls/i686/cmov/ (0x0055b000) => /usr/lib/ (0x00110000) => /usr/lib/ (0x00880000) => /usr/lib/ (0x004cd000) => /lib/tls/i686/cmov/ (0x00ade000) => /usr/lib/ (0x00d35000) => /lib/tls/i686/cmov/ (0x00b8a000) => /lib/ (0x001cf000) => /lib/tls/i686/cmov/ (0x005a1000)
/lib/ (0x00584000) => /lib/tls/i686/cmov/ (0x009c5000) => /usr/lib/ (0x00b54000) => /usr/lib/ (0x0011d000) => /usr/lib/ (0x00702000) => /usr/lib/ (0x0079d000) => /usr/lib/ (0x0014c000) => /lib/ (0x00170000) => /usr/lib/ (0x00180000) => /lib/ (0x00174000) => /usr/lib/ (0x00188000) => /lib/ (0x00199000) => /lib/ (0x008b2000) => /lib/ (0x00178000)

now if one of those entries shows no hex number there or zero, the library is missing.

once you know which lib is missing, you can install missing package and use the plugin.

Well for one… mine is 18315… about to run ldd now

Seems Im missing many ? => not found => not found => not found

I tried apt-get install for all 3 and can’t find them…

Should it be ok that I have … and you referenced … ?

I’m trying to install these now looks like ia32 libs is obsolete…

lib32z1-dev lib32bz2-dev

I’m on 64 bit ubuntu probably my problem… either that or combination of that and outdated plugin… Let me know when you get a chance if you have any magic solution ha

still no good… its stilling me CURLSMBS doesn’t exist

make sure you have the libs, that’s all I can say.

maybe better use 32bit ubuntu?

libidn is LGPL. I can’t link it in plugin, you have to have it.

Can you link me too recent version of plugin site a bit confusing

14.2 download is here: