How to force Xojo to NOT use the Builts folder ?

Yes, you may say:

Uncheck in the Options window the correct CheckBox.

You are right, BUT this does not works for me (2014r3.1).

Even deleting the previous data before building the application, I get a message telling me that Xojo will overwrite some files.

In my project folder, there are two items: a folder whith previous project versions (project backups) and the project itself.

So, when I build the application, I get the builds folder, the Windows folder inside it and, at last, the application and Libs items.

Emile are you saving your projects in Dropbox?

Hi Wayne,

no, I do not.

Also, this is new (maybe with 2014r3.1 ?), it dates drom some days ago. BUT: I was so in a hurry that my memory is unable to give a hint on where in time this happened to me.

FWIW: I set the Options to fit my needs while the project was open. I changed the values (with a click at the bottom of the Navigator pane) and build.
I quit Xojo, restart everything to get the same result.
I quit Xojo, Power Off the Windows machine, wait a bit and restart the whole process (be sure the behaviors are what I want, load the project, THAT project, build) and have the same result.
At last, I Powered Off the computer, wwait a bit (drink a cup of coffee), Power ON, run Xojo, check the behaviors, load THAT project and Build: no change at all.

As I stated previously, I delete (not send to the Trash: DELETE) the Builds folder before build another application.
I also save (try to save) each time I made a change.

At last, I asked here just in case something wrong (my fault or not) happens / to get reports / advices to get out of this.

BTW: I didn’t have Internet active while I was doing that.

Nota: neightbours with WiFi exists around me, but I do not connect to these (closed) WiFi.

Hi Emile,

I just wondered because I’ve had the same problem when I have a slow connection to the Internet and Dropbox hadn’t caught up. Obviously not the problem that you’re experiencing though.

When you say “send to Trash” I’m guessing you’re running on OSX and that’s totally outside my area of expertise (if I have one).

So all I can do is wish you a happy new year & hope that an OSX user will be able to help.

No Wayne, I meant Windows 8.1. Windows have two features: Send to Trash and Destroy right now. I always use Destroy right now (press the shift key while right-click).

However, I realized seconds ago that I do not installed Xojo 2014r3.1 !

How was it possible ? Don’t know. I will install the latest update right now.

It sounds like the IDE is having trouble writing the project preferences file.

Hi Greg,

Thank you for your answer.

a. I had troubles installing Xojo 3.1: windows refused to allow me to do that. My second chance comes from the Options… Updrate button, but this destroy my ability to build applications (I had to re validate my valid license).

b. This is doing the same with Xojo 2014r3.1.

What can I do (trouble writing the project preferences file) ?

While I am with the preferences: my project rarely displays my Navigation pas like i leave it at project / Xojo close / quit time: is it the current behavior ?
(Most of the objects in the Navigation pane stays ‘closed’ even if I open them before quitting Xojo.)

Navigation pane state is stored in the same place. If you are saving in text format, you should have a file next to the project with a .uistate extension. Quit the IDE, delete that file and try again.