How i add two entry to info.plist

I need to add this to my IOS app




  1. create a text file - name it info.plist
  2. in there put
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist SYSTEM "file://localhost/System/Library/DTDs/PropertyList.dtd">
<plist version="0.9">
  1. drag this file into your project

No works
“Coop_Asambleas” does not contain a valid Info.plist, so it cannot be installed on iPad

(“CFBundleExecutable” is not specified)

Create a new plist file in Xcode
Add key/values
Save file
Then drag it into Xojo.

works dandy here when I run a new iOS project

let me try in Xcode


I do this code and same error msg
Any idea way

[code]<?xml version="1.0" encoding="UTF-8"?>

NSAppTransportSecurity CFBundleExecutable Coop_Asambleas NSAllowsArbitraryLoads [/code]

Move the NSAppTransportSecurity down two lines, just before

Remember, these are key/value pairs like a Dictionary in Xojo. Key defines the name and the item immediately following it is the value. In this case, a dictionary which contains more key/value pairs. Having two keys in a row is what’s confusing things.

hi Greg
Can you create the file for me i try like 20 times and same error using Xcode.

i have same error

copy and paste the one I posted into a text file
name that file info.plist
drag that text file into the navigator in your project

if this doesnt work then you havent followed the steps PRECISELY

“Coop_Asambleas” does not contain a valid Info.plist, so it cannot be installed on iPad Ada

(“CFBundleExecutable” is not specified)

my code <?xml version="1.0" encoding="UTF-8"?>

< CFBundleExecutable Coop_Asambleas NSAppTransportSecurity NSAllowsArbitraryLoads

if i try to edit with Xcode this error show up )The data couldn’t be read because it isn’t in the correct format.)

right - what you posted above is NOT a plist
it completely malformed

you keep doing something different than what people have advised (certainly not what I wrote)
as long as you do this you will probably have issues
go back to this post
follow those steps EXACTLY - dont add things or remove things or make up new things to add to the plist
JUST do EXACTLY those 3 steps

that has nothing to do with a plist

the plist can use name like coop.plist or no

follow the instructions I posted and get it working first

now info.plist works but no works the

i guest no authority in Xcode 11.3
connection from iPad using internet i have this error The resource could not be loaded because the App Transport Security policy requires the use of a secure connection.

Now works Perfects with

<?xml version="1.0" encoding="UTF-8"?> CFBundleExecutable Coop_Asambleas NSAppTransportSecurity NSAllowsArbitraryLoads

I am using my iPad app with Valentina Server with sqlite and rest api by internet now is working all good.

thanks to all help and Valentina support

I would guess that if you remove the CFBundleExecutable you would find that this key is already generated by the IDE
This is literally the name of the EXE file and the IDE & compiler should not be using whatever value you put in there otherwise you risk breaking the iOS app or making it not run. The compiler and IDE use the name you put in the specific target settings and should ignore this value in the plist