How do I Install Libsoup 2.4

Hi all,

Wondering if anyone could provide me the commands to install libsoup on Ubuntu 14.04


I was able to install libsoup2.4 by running the following command:

sudo apt-get install libsoup2.4 (Face-palm)

But my webapp still won’t POST with Xojo.Net.HTTPSocket (#NOTE: it works on Windows)

any ideas?

64-bit? If so you’ll need to install the 32-bit library.

sudo apt-get install libsoup2.4-1:i386$64-bit-configuration

Thanks Paul,

I installed the 32-Bit Library you suggested but still no luck … should I restart any services?

I tried compiling to 32bit but same issue :frowning:

Are you getting a specific error that makes you think that libsoup is the problem?

On Ubuntu Server 14.04 (64bit) I used the following commands, which made it work for me:

sudo apt-get update sudo apt-get install libsoup-gnome2.4-dev

Thanks @Oliver. My WebApp crashed and after pondering what I changed in the code I came up with replacing HTTPSocket with URLConnection. With your tip, everything is working again :slight_smile:

OT: I notice that I wrote the above post exactly today, two years ago - and this is my birthday. So your success is a nice birthday present. Happy birthday (to me).