How do I completely uninstall Xojo and clear out all settings, prefs, caches, etc from Windows?

I have a windows 7 computer that a coworker uses for Xojo development, and his version of Xojo has become VERY unstable - i.e., he cannot run any project in the debugger for more than about 30 seconds before all of Xojo comes crashing down.

Before I file bug reports that are hard to reproduce etc, I thought we had better try resetting his copy of Xojo to defaults and see if the behavior changes.

Only problem is: I can’t find everywhere that Xojo leaves stuff on a windows computer.

What are the magical locations I need to delete in order to completely re-install a clean copy of Xojo on windows?

It’s all in User\\AppData\Roaming\Xojo

Registry - preference settings are there
Check both HKEY_CURRENT_USER\Software and HKEY_LOCAL_MACHINE\Software

Users “AppData” - usually in the roaming profile

The installed program files

Normally, nuking the stuff in appdata is enough to make Xojo magically start behaving again.

Usually - but Kimball asked for the “nuke everything” option :slight_smile:

Thanks everyone - I believe I did get everything, but am still having the problem. One thing I noticed: After doing the full nuke, after reinstalling and restarting Xojo, my license was magically back on the dev machine…does that mean I missed a location somehow, or does Xojo reach out to license servers on startup and grab a license based on a machine UUID or similar?

If I can boil down the project that is especially problematic into something I can share, I will… but this project talks to a piece of hardware that we can’t really share with Xojo dev staff.

We have tried several of the example projects that ship with Xojo, and have no issues with those… So there must be something specific about this project that is exposing a problem in the debugger.

What if you create a new user account & use that ?

@Norman Palardy we may try that today - also going to try installing Xojo on a different windows 7 box and running this project.

After several hours of careful elimination and guesswork, I have boiled down the exact cause of the IDE lockup to calling system.debuglog() too frequently. I’ve created a bug report in feedback with a sample case attached.

I’d love it if some others could test the attached project on their copies of Windows to verify the issue. This is not an issue on the Mac at all, and has only been a problem since 2014r2.2 (I believe).

Here’s the feedback case: