Hint how to solve web app not starting locally without any warnings

Quick hint in case someone else might run in this kind of issue.

What happened?

  • I continued today some work on JSON for a Web 2.0 app.
  • Therefore I activated a third-party plugin.
  • When running the App, it got compiled but it didn’t start, no warnings, it just didn’t start.
  • I closed Xojo, uninstalled the said plugin, restarted Xojo: the same issue.
  • Assuming it could be some memory leak or alike and putting on blame on Xojo, I restarted my Mac, but the same behavior occured after the mac was rebooted.
  • Reverted back via git to the latest working version: still not working!
  • Okay, opening one of the Xojo examples: ouch, not working either!! …
  • Must be the beta version I used, trying the last stable release: the same issue!!!

After some further investigations: the root cause was simple but not evident. Another web server was running on the localhost ! Ouch :slight_smile:

In my case, the root cause wasn’t obvious. Besides activating the new plugin (which isn’t causing any issues whatsoever), I had started at the same time a tool called “Smart JSON Editor” for macOS. Little did I know that this program starts an own webServer on the default localhost and port, so the same port Xojo Web is using …

The solution is simple:

  1. Either you can change, like in my case, the port of your tool.
  2. Or quit that particular application.

I believe other users might run into this kind of challenge. If you are running a web server locally on purpose (i.e. MAMP etc.) you will probably remember and see the root cause instantly. But be aware that tools, you only work with from time to time might launch an own web server, even if you are not aware that they do …

Yes I saw this when running two Xojo sessions and wondered why when I ran the web app in one it just closed without any message or warning. Took me longer than it should to release that I had another session running a debug build using the default port.

1 Like

true that’s a possible scenario as well for this “challenge”, didn’t think of that one.

Don’t worry, same here, I thought first I’m again an absolute beginner :-). I don’t think there is much Xojo could do to catch this “exception” other than a popup warning us about doing stupid things :-).

Same - had me scratching my head, looking at various settings etc. Doh.

1 Like

Been there done that, have the T-Shirt…

1 Like

We are “pros” aren’t we?!? :slight_smile:

1 Like

My FR on the topic from a few days back: <https://xojo.com/issue/61458>
If you try to debug run two webApps at the same time, and both use the same Debug Port, the IDE will compile and launch the second one but then fail silently.

Expected behavior:

  • Since the IDE knows the port #s, it would be better to put up an error message “Project Foobar uses debug port 8080 which is in use by another app. Change the debug port to allow debugging more than one webapp at once”

(My request is specific to debugging 2 Xojo web apps at the same time. I think you are asking about the more general case where anything is using the port).


Correct, I wasn’t really asking, I bumped into the trap this morning, as I didn’t know that the app “Smart JSON Editor” is opening by default a web server, never used that Webserver and I’m working with that app for quite a while :-).