Hide Minimize/Maxmize & Close on MessageDialog

Is it possible to remove the top bar of a MessageDialog thus removing the minimise/maximize/close icons.

Are you sure you mean a MessageDialog and not a window? I don’t see any window controls on a MessageDialog.

For a window, you can unselect the following in the layout mode of the window, to remove the buttons.

  • Has Close Button
  • Has Maximize Button
  • Has Minimize Button
  • Has Full Screen Button

You could also change the window type to “Modal Dialog” to remove the entire window title bar.

There are other options available via Declares and Plus-ins.

I think there are on Windows, no?

They appear on a Linux compiled app (Raspberry Pi).

Code is:-

Var d As New MessageDialog // declare the MessageDialog object
Var b As MessageDialogButton // for handling the result
d.Icon = MessageDialog.GraphicCaution // display warning icon
d.ActionButton.Caption = “Save && Reboot”
d.CancelButton.Visible = True // show the Cancel button
'd.AlternateActionButton.Visible = True //Show the Alternative Action Button
'd.AlternateActionButton.Caption = “Save && Reboot”
d.Message = “Do you want to save changes & reboot”
d.Explanation = “If you don’t save & reboot, your changes will be lost.”
b = d.ShowModalWithin(MainWindow) //display the dialog in the window

you could make a custom window set it’s frame to PLAIN Box or something similar.

If other applications on the same OS show MessageBoxes without these icons, then it’s a Xojo bug and should probably be reported in Feedback.
If they don’t, the buttons should appear.

Make your choice :wink:

1 Like

Submitted a bug via feedback.

Any update on this? I appreciate Nick submitting this. Have just encountered this myself.

I don’t get any minimize or maximize controls in MessageDialog on Windows. I can’t speak for the other platforms.

Seems to happen on Raspberry Pi compiles.

Raspberry Pi is where I picked up the issue but I believe it affects linux generally.

Is there an update regarding this. Bug submitted via feedback in December, but fix hasn’t reached the latest release Version 2020 Release 2.

There was a Xojo 2020r2.1 Virginia !

Sorry yes R2.1 has the same issue so not fixed.

Following, same problem on Linux. Tried to disable the close and minimize button both via inspector and code but they are still there when using modal dialog. Anyone has a solution?

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.