Handle URL Socket Hang Up

Hey Y’all,

I’m running into an odd issue and I can’t seem to figure it out. I’ve created a REST API with Xojo using the HandleURL. My app is functioning fine until I request large datasets that takes time to organize into JSON. I’ve used POSTMAN, PHP CURL, JQUERY to test my API.

If I run the app in debug, call the GET with POSTMAN it will wait for a second and return with “Error: socket hang up”. Then a second later I can see the API finishing the response. I’m getting simliar errors with JQUERY/CURL (No response). I’ve tried sending a response status of 102/100. I’ve set the timeout for POSTMAN to infinite and 2 minutes.

For context this method/query is taking about 16 seconds to gather the data in Xojo and respond. POSTMAN seems to return with “Error: socket hang up” at about the 9-11 second mark. I checked with the firewall team and it seems to be functioning correctly. I’m currently out of ideas, I’m all ears!

Using Xojo Release 2023r1.1
I’ve also tried it in Release 2022r4.1