Grey in IDE windows. Can't see what I'm typing.

What did I mess up?
Text areas in IDE are gray but accepting typing, and when typing only bars show.
This is for example the code area in an event handler.
Other areas are also grey:

Setting a breakpoint will display the code line typed:

The simplest case is: I start Xojo, Chose a new Desktop project (just double click ‘Desktop’), add a pushbutton, end Xojo by clicking the red cross.
When the dialog box shows there is no question to the buttons Yes, No and Cancel

  • just the yellow Warning icon:

I use Windows 7/64 Sp1. Plenty of memory and disk space.
This all started when I was trying out the Remote Debugger Desktop in 2017r1.1
on a Linux target.

I guess I messed up some Windows file, but other applications seem to work fine,
like RB2012r2.1. (Yes, I have not kept up. Maybe I’m just missing a modern feature here :slight_smile:

I tried the basic things like restarting, reinstall 2017r1.1, re-download Xojo, memory test.
I am reluctant to try System Restore as there is no good restore point now.

What might have become damaged?
Any ideas, please?


[quote=329237:@Lennart Ramberg]What did I mess up?
Text areas in IDE are gray but accepting typing, and when typing only bars show.
This is for example the code area in an event handler.

For some reason, your pictures don’t display. I have simply copied the URLs above.

Looks like something is wrong with System font. Have you deleted fonts recently ?

I would try a system repair from the install CD. It won’t change your present system state, but it will reinstall the basic fonts.

And … Make it a habit to have restore points that mean something. You never know when you need them. Or backup, backup, backup. I do images of my system once a week, religiously, on two different external drives.

Working links to the screenshots might help.

Have you tried another computer?

Thanks Michel for quickly adding the links. I think I followed the instructions for inline pictures though.
No, I didn’t touch fonts recently. And in any case, should the code area in the Event Handler not be grey, but white.
I just assume it would work correctly on another computer, so I haven’t tried that yet.

You’re welcome. You did use properly the img tag. I do not know why Imgur would not display.

About your particular issue, could be something else, but the first picture of the editor shows suspicious vertical lines where characters should be displayed. Which made me think fonts could be involved.

Try with another version of Xojo as well. 2016R3 and previous use a different handling to display. If what you see is a side effect of Direct2D, previous versions may very well display quite nicely.

With 2016r3 there is no such problem! :slight_smile:
Thanks again Michel.
It seems I didn’t damage or mess up anything after all.

I will ponder over how to go about the 2017r1.1.

You may want to verify your system is up to date. For me, Windows 7 is far away in time, but it is possible you need a service pack for Direct2D support.

Sometimes, creating a new account and trying again may solve issues.

If your machines supports it, I advise Windows 10. It is what Windows 8 should have been. Meaning, modernized Windows 7. You should feel right at home. And since it is the standard today, it makes sense for development.

The update of W7 did the trick!
All is well.
Excellent help. Thanks.