Getting Started..

Every now and then I wonder if there is anything useful in this Web stuff, as my impression formed over the last year or two is that the control sets are limited and its a pain to deploy.

Having a bit of time this weekend, I thought ‘well, I have a lot of experience with RB now, how hard can it be?’
So I started a new Web project in Xojo and set about to create a dialog with a text box and a list box.
I already failed in a few ways, so I was wondering if anyone can give me some feedback on the following:

a) There ‘is no listbox’ ?
Now, I know there is, but…
I mean I open the library floating window and there isn’t a listbox there.
I opened a sample project with a list box, and I can see one. It is a WebListbox, but I can’t add one to a new project.
I found I can take a canvas and set the super to WebListBox. That doesn’t make it become one, however. And as soon as I turn my back Xojo resets the super anyway.

b) I can’t trial it.
I see Xojo launches the app in a browser window. Makes sense.
But unlike the trial versions of RB, I can’t seem to make an app to put online and check that it will work end to end, unless I buy a build licence.
Well, not surprisingly I don’t plan to buy a build licence only to find that my host doesn’t work, or that Im incapable of writing a useful web app.
Is there no time limited build option?

c) Xojo is really unintuitive.
I know this has been talked too death, but it hasn’t really affected me so far.
Ive been designing my apps in RB 2012 and compiling in Xojo.
Trying to use Xojo to create an app from scratch is mind bending. I imagine it will become clearer if I spend time in there to the exclusion of RB, but Xojo’s IDE feels like a big step backwards despite Xojo’s ‘build an app in an hour’ campaign.

a) There is definitely a ListBox for web apps. It’s here in the Library:

b) Xojo does not allow you to build without a license. You can download pre-built apps for testing from here.

c) Perhaps you misunderstood the “Hour of Code” posts. They are not our campaign, but were part of an effort organized by Computer Science Education Week and to get people to spend an hour learning about programming.

OK. I went to my setup to take a screenshot and show that mine didn’t have it.
Then I realised that the whole library window is a scrollable area (yes, you know that, and I do now, but it wasn’t obvious)
Your whole library looks different mine, so Im guessing the R3/R4 IDE is a little different.
Got it.


You don’t see a scroll bar?

You can use the “gear” button at the top of the Library to change the layout. I have mine set to “Small Icons and Labels” and “Show Group Banners”.

Definitely grab Xojo 2013r4.1 if you are using an older version. The new one has lots of little UI improvements.

Blame Mavericks.
You knew where you were with Aqua.

Thats what ‘nothing on the telly over Xmas’ is all about.

I see the standalone app needs to be ‘started’ on my server. So since I don’t seem to have execute ability for apps on the host, I decided to try the CGI version.
Uploaded, tried to run.
Got a message to say that the CFG file wasn’t writable.
Changed permissions on everything

Tried again, got ‘unable to launch on port 46303’

Troubleshooting says CGI shouldn’t need the port to be manually set.
It also says that you need to add AddHandler cgi-script .cgi to the .htaccess file

Mine now says this in that folder, but still nothing doing:

order allow,deny deny from all <Files *.cgi> allow from all </Files> AddHandler cgi-script .cgi

Sounds like you might be using a shared server of some kind? Getting Xojo web apps to run a shared sever is usually a losing battle. Shared servers are usually locked down tightly and don’t often work with Xojo web apps “as is”. A Virtual Private Server (VPS) is your best bet for now.

Oh well.

You can get a free Amazon EC2 micro instance for a year. It’s great for testing web apps.

Might be worth looking into.