Getting 'Can't find a type with this name' error

I am new to Xojo and am having a problem using any non UI plugins in my projects. Using Xojo r3 on a Windows 7 Home edition machine. I am trying to create an instance of a class from a plugin and am getting an error stating “Can’t find a type with this name”. I have checked to make sure I have the plugin installed in the plugins folder, and the plugin is visible from Help, About, Loaded Plugins. Pressing Tab when selecting the class name also brings up the correct name in the list.

I created a desktop project and added an Open event handler on Window1. Added just this line of code “Dim P as New DynaPDFMBS” and get the error.

I have tried several plugins and am getting the same behavior with each.

I saw an older post which described the same problem, but the post was a couple of years old, and uninstalling/reinstalling Xojo solved his problem. I tried uninstalling/reinstalling and still have the problem.

Any help would be appreciated,


Some plugins require other plugins to be installed. Make sure you have everything installed that is required.

Otherwise have a look at the examples included with the plugin, e.g.

Seems Christian always subclasses DynapdfMBS.

Also not sure if the capitalization makes a difference.

P.S. what happens if you Ryan to run one of the included examples?

Also (happened to me as I have several Xojo versions installed) make sure the plugin is actually installed for the Xojo version you are using.


Thanks for the reply. I also had several versions installed, but verified I had the plugin in the right folder. I am experiencing the same problem on any example included. I am also having the same problem with other plugins (tried ENet plugin from Einhugar). I have since uninstalled all versions of Xojo and reinstalled version 2017r21. The example programs for the DynaPDFMBS plugin have a class inserted into the project called MyDynaPDFMBS with the super defined as DynaPDFMBS. When the example is run, any reference to any member of the derived class displays the error "Type MyDynaPDFMBS has no member named “xxxxxxxx”

I am kind of at a dead end. Not really sure what to try from here.

Is there anything required to use a plugin other than having the plugin (and any dependencies) installed in the plugins folder?

Any chance that installing multiple versions of Xojo corrupted any registry entries that did not get removed when uninstalled?

Any ideas will be appreciated.

You might want to post to the correct subforum with a better title for the DynaPDF plugin. Or you contact Christian directly.


I realized after I posted to the ‘General’ sub-forum that the ‘Getting Started’ sub-forum may be the more appropriate forum to post to. I do not think this is a DynaPDF problem though, since as a stated in prior posts that the problem exists with all of the plugins I have tried, including plugins from Einhugur. This seems to be a Xojo problem that has arisen since installing Xojo2017r3. Some of the example projects from plugin developers ran on 2017r21. Since installing 2017r3 they will not run of either version.


Well, did you install the DynaPDF Plugin from us?
Does it show up in the Plugins list in about window?


I apologize. The problem does seem to be with DynaPDF. After posting the last reply, I deleted everything from my plugins folder and copied Einhugur’s, Enet plugin into it. It worked fine. After that I copied Einhugur’s PDF plugin TypLib plugin (dependency) and it worked fine. Following that I copied DynaPDFMBS and MacCG Plugin (dependency) and examples would not run. Following that no plugin would work, even after quiting and restarting Xojo. The only way I could get them to work was removing DynaPDFMBS and MacCG plugins from the plugins folder and restarting Xojo.

I will post this information on a support forum for DynaPDF.

Thanks for all of the replies.


Yes I did install DynaPDF from you. I purchased the Starter edition this week. I did show up in the About Plugins list. Just none of the examples would run.


Well, you can’t install macCG alone. See dependencies:

You need Main and MacCF for MacCG.

DynaPDF should work alone.


Adding the two other plugins solved the problem.

I checked the documentation for DynaPDFMBS and it said there were no dependencies for it. I then
looked in the documentation for the example I was trying to run and it stated that the only plugins required to run this example were DynaPDF and MacCG.

/DynaPDF/Create and print PDF
Required plugins for this example: MBS DynaPDF Plugin, MBS MacCG Plugin

I guess I should have looked further at the dependencies document you referred to. I will do further reading next time.

Thank you very much for your help.

Let me change my dependencies tracking to include dependencies.

The example builds and than does not contain main or macCF plugin parts.
But you need them to compile it, even as they are not included.

Ok thanks, I understand now.