Firewall stopping debug access

Hi,
(win7 64 bit)
I have returned to Xojo with an old RB database program that I need to bring up to date. The original program will compile and run correctly, but when I try to run it under debug I get an error message stating that debug can’t communicate with the Xojo IDE and suggesting that I reconfigure the software firewall to allow localhost traffic on ports 13897 or 60554.

A quick google on the subject has left me totally confused, how do I go about fixing this problem?

Regards,

Doug Neale

If your firewall is blocking the ports the Xojo debugger uses then it won’t be able to connect. It could also be that the port(s) are in use by another program.

So are you running everything on the same computer or are you trying to debug remotely to another machine?

Everything is on one computer and Xojo 2014r1.1 is in the Inbound Rules list of the Windows Firewall.

You’ll need to add an exception for Remote Debugger to Windows Firewall as well. It acts like a server and needs to listen for connections.

1 Like

Hi Greg,

How do I do that?

It isn’t available as an option as far as I can see, so I can’t just tick a box!

The rules and terminology have to be exact for it to work and not mess up everything else.

Control Panel —> Windows Firewall —> Advanced Settings

Remote debugger needs tcp/udp inbound and outbound rules

As Remote Debugger isn’t in the inbound or outbound rule list already, I guess I have got to invoke a new custom rule for both in/out and call it ‘Remote Debugger’.

Or do I start with a new ‘Port’ rule for TCP and UDP separately and then specify one or both the port numbers that were quoted in the first error message from Xojo?

Douglas - On my Windows 7 VM, I was simply able to add the "Remote Debugger Desktop.exe” as an allowed program.

Here’s a link to a pdf that may (hopefully!) help.

if this is all on one computer there’s NO remote debugger stub rule required as there’s NO remote stub required

you should be getting a popup warning saying that the firewall has blocked a program from connecting & you should be able to just permit it

Douglas - Oh. Think I misunderstood the post. What I posted was for Remote Debugger and it sounds like maybe you can’t debug with the Xojo IDE itself? If so, sorry for the misunderstanding and incorrect information I shared.

Norman - I’d assume that you could add manually add Xojo the same way as in the PDF I linked (just select Xojo instead of the remote debugger). Is that a safe assumption?

1 Like

Unfortunately, I’m not using VM and those options don’t appear in my version of Windows 7 (64bit Ultimate) which is running in a Bootcamp partition on a MacPro.

If I can’t get it to work I’m going to try running under OSX to make the changes then just compile it for windows as the last pass.

I’ll start again tomorrow, I may have some new ideas in the morning.

Goodnight from the UK

Doug Neale

I finally got it sorted out!
Here are the necessary settings (which work for me)
Control Panel–>Windows Firewall
Allow Programs to communicate through firewall–> ADD Xojo (select from program list)

      Windows Firewall (Advanced Security)  --. add Xojo Debug to Outbound Rules:

Properties: General: Name: Xojo Debug
Action: Allow the connection
Programs & Services: All Programs that meet specified conditions
Services: Apply to all programs
Computers: no settings
Protocols: Any protocol,all local,all remote
Scope: any,any
advanced: profiles: domain,private & public
interface types:all

Hope that helps anybody else who gets into the same problem

Doug Neale