FileUploader Plus (+) Button Not Working

I add the file uploader to a page. Push +. Nothing happens.
I tried the example project that comes with Xojo. Nothing happens.

Xojo 2019.3.1

HI @Bob_Gordon
You can take a look this topic like your trouble on forum: web file uploader questions
Or you can show your code bellow to easy help you resolve trouble.

Thanks for your suggestion. It appears, however, that what was discussed in that topic is not the problem I’m having.

Some more info: I had another project where I previously used the file uploader (All that appears on the screen is the + because it should only do one file) successfully. I ran it, and it also does not work.

Does the uploader work in a simple project all by itself?


I tried the example project that comes with Xojo. It also did not work.
I have used it successfully in another project.
As I understand it: Place the control on the page. The plus button should bring up a GetFile dialog. One then must deal with various events and methods to get the file.


My guess then is that something changed in your browser recently which is causing this issue.


That was my thought. So, what’s likely to affect this?


What browser are you using?


Note: This has worked in the past.

so interesting. 2019r3.2 running on my machine with Safari 14.0.3 on Big Sur:

so I’m not sure what’s going on with your machine.

Have you cleared your browser cache recently for localhost and

What version of Safari? If it’s 14.0.1, there was a bug in Safari that caused this if you didn’t use the ACCEPT attribute on the uploader, and even then it sometimes failed.

EDIT: Can confirm that Web 1.0 did not add the ACCEPT attribute to the file INPUT element.


From what I’m reading, 14.0.2 also exhibits this bug.

Updating may not fix it, but it’d certainly rule out a potential cause. Do Web 2.0 File Uploaders work on that machine?

Yes. I tried Web 2.0. It works. The problem is that converting this project would be a major effort.

Nah, we need to find the cause. Unfortunately, if it’s not Safari bug, then I’m at a loss.

Update: Just came back from a walk. There was an update for the Mac. It turns out to have been for Safari. Now on 14.0.3. Tested the example project. Now working.

Thanks to Anthony and Greg for helping.

1 Like