FileMaker Pro 15 doesn't recognize my app

I am trying to send an event from Filemaker 15 Pro to my App. After selecting the ‘Target Application’, it appears as “”. If I try to send an event I get ‘The file could not be found and is required to complete this operation.’ That was working fine in previous FM versions but not the last ones.

You are sure that your app is scriptable?

Yes it is, the application has an Applescript dictionary you can see by dropping the app to ‘Script Editor’. I even tried to create all kind of scripts and they all work. The problem is FileMaker 15, after I select the target app it is displayed as ‘unknown’ and there is no way to send events. I don’t use Applescript here, just send an event.

This may be more for the Filemaker folks. I only have FM13. I use polling for communicating with Filemaker.

Is your application in the… Applications folder ?

Did you try (I think so) to send orders from the Script Editor ?

Did you try to get the name of all process while your application runs ?

tell application "Finder" return name of every process end tell

I tried that and the app name is displayed. I finally decided to send data using Applescript from inside FM, indeed there is an option to run Applescript and since the app is scriptable, it works. However I did not found a solution to the problem of sending events directly. It doesn’t work.

Next questions…

a. Are you storing the FileMaker data base contents into your project ?
b. Isn’t there a driver available to do that directly ?
c. ???

On google:

FileMaker and Xojo

Good luck

No, actually I created a button in FM that is linked to a FM script. That FM script were sending an event. It stopped working with FM12 actually. What is funny is that if you try to select my app as the target app for the event, it accepts it but later it appears as ‘unknown’.

I encountered the same problem.

  • Open info.plist (in /contents of application)
  • Bundle creator OS type code HAS key "??? "
  • Set key (required for FileMaker).

See feedback#43026

Shouldn’t then a

tell application id "com.blablacom.something"


The only bundle key set to ??? I can find in the plist is ‘CFBundleSignature’.

Have you tried my suggestion? I’ve just tried a minimal script myself. With the bundle id executing the script works.

tell application id "com.mothsoftware.mailarchiverx" «event MaxSarch» 'event to start doing something in my app end tell

in plist of your application ? build with Xojo version ?
See info.plist image.

I’m having the same problem. The apps I made with Xojo/REALbasic years ago don’t have it, the can be opened by sending an event from Filemaker without any problem.
But apps compiled by recent versions of Xojo are not recognised.

It could be a Filemaker problem because when you use the Script Editor (Mac) the app responds correctly.
The creator code = “???” but it also doesn’t work when i change it to something

But nevertheless, something has changed.
I use the latest Xojo (2017 release 2), the latest Filemaker( and the latest Mac OS(10.12.6)