File path issue with Win10 when running as an administrator

Hey guys,

Here’s a good one for you. I’m running Windows 10 in a Parallels VM on my Mac. I have my Mac’s “Home” folder published as the “Y:” drive in Windows. To Windows it looks like a network drive.

I have a file on that drive that one of my apps is using for some testing. When I run the app in normal mode, it accesses this file just fine. However, when I run the app as an administrator, the framework says that file does not exist. I’ve seen this in the debugger. I don’t understand why the file exists in normal privileges but when running elevated privileges the framework doesn’t see that the file is there.



Guessing, but if the ordinary user is not the same user as the admin user, the drive is probably not mapped for the admin user.

I had this problem once & patched the registry to fix it. Not good for end user apps though. Have a look at

You can use a shell to action net use… which will work for the current run of the application.

Thanks guys. The odd part is that the “network” drive is set up by Parallels at the top level. So it should be shared and mounted for any account.

Additionally, if the drive was not mapped under the admin account, wouldn’t the folder item pointing to the network drive return Nil? To me that would make more sense. But it isn’t. The folder item is not returning Nil for either the file I want to read or it’s containing directory hierarchy. The framework is simply reporting that the file does not exist. Then I try to create the file which causes the problem too. I’m not sure why I can’t create the file (SQLite doesn’t tell me that) and I wouldn’t want to create it as it already exists…

Just an off the wall thought but does the VM admin allow foreign admin accounts? Some systems don’t allow it due to not wanting to allow the extended access rights that admin accounts have.