failure to install/download XCode

something strange going on. As I said in another post, I could not install XCode from App Store app because my connection dropper.
I was kindly advised to download it with Safari at
After several hours, at the end of the downloading process, when I double-clicked the file, I got a message that the file was corrupted.

So I asked my brother to download it for me. He has got a good connection and in about half an hour downloaded it, but he too, double-clicking the file, got the same “corrupted file” message. He tried several times with no success.
He even tried to get it from Apple website. Same message.

At this point I wonder if there is something wrong on the Apple site.

What version of macOS are you using?

I doubt seriously if it is an Apple problem, because if it were, there would be thunder rolling on the Internet, and Apple would have it fixed in mere seconds…

I downloaded in to my wifes new MacMini just yesterday… works fine

Error message when I want to download it with El Capitan:
Xcode ne peut pas tre install sur Macintosh HD car OSX 10.13.6 ou ultrieur y est requis.

Xcode 10 requires a Mac running macOS 10.13.6 or later.

Sorry, its late, I do not noticed the french message :(.

Both my MBP and my brother’s iMac are using 10.14.2. And we have been downloading from different countries.
Strange behavior indeed.

I suspect that probably a local cache server has a corrupted file, normally stuff like this gets corrected in about 24~48 hours. Failing that, I would recommend contacting Apple.

@Sam Rowlands

That is also what I suspected; although my brother downloaded it from Italy, me myself from Asia, and Dave successfully from USA.
Today my brother may try from the Apple Store nearby his place. So let me wait and see.