Failure on installing a provisioning profile on my iPhone

Can anyone tell me why I no longer can install a provisioning profile on my iPhone?

I try to install a new Apple Developer provisioning profile on my iPhone 12 Pro in order to use it as a testing device for an iOS app. I am following the procedure as described in the Xojo documentation, but installation fails with the error message: “Failed to install one or more provisioning profiles on the device”.

This video is a screen recording of the whole process, from generating a certificate up to uploading the profile to the iPhone.

Youtube Video, screen recording: creation and installation fail


MacBook Air, M1 2020, macOS Ventura 13.2.1
Iphone 12 Pro, iOS 16.3.1
Xcode Version 14.2 (14C18)

First, check and make sure your device is registered in your Apple dev account. Then make sure the development profile for your app has that device checked. If not, edit, add, save and download the profile again.

1 Like

Well, I did this several times and I’m still getting the fail notice from Xcode: “Failed to install …”

But then, I started Xojo and found a correct Team entry in Build Settings->iOS->Code Signing! I have no clue why this suddenly is working.

The only other thing I did in between, was opening finder, and then in the navigation panel I selected my iPhone in the section “locations”. It then took a moment to load.

I have difficulties to imagine why this step should make a difference, but from then on it worked.

I hate it when things do not work and then suddenly they start working, and I have no clue why…

It could be that your device was not set up for development. That lag you saw after plugging in your device was probably that process. Usually I see that when I open the Xcode devices & simulators window. It says something like “preparing device for development”

1 Like

I had issue with profile and went to this error at some point .
1 - assuming you are using USB cable, plug the cable between Mac and Iphone
2 - open Xcode, in windows menu, open your “devices & simulators”
3 - Check if you see your phone in the list. If not,
a - check if your phone is enabled for dev AND that the process is finalized ( it took a lot of time for me ). I recommend to reboot the phone as well as I got it working after a reboot.
b - try to build a basic app with Xcode and check if it works or not.
if b works, the solution which worked for me was to reinstall the phone completly ( it solved as well other errors I got ).
I’m rookie on IOs dev, so just sharing my light experience. Hope this helps !

1 Like

I had the same issue where I could not load the provisioning profile.
This is what I did and solved the issue:

  1. Deleted all provisioning profiles from ~/Library/MobileDevice/Provisioning Profiles
  2. Restarted my M1 Mac
  3. Opened Xcode Accounts → Download Manual Profiles

Then everything started working as intended. Probably you already restarted and did that, but I just wanted to record my experience with the same issue.