Failure Condition: mClassPtr Crash

We are trying to run one of our Intel Linux console apps in an ARM Linux VM on an M1 Mac via Rosetta 2 (Apple added Rosetta 2 support for ARM Linux VMs in Ventura).

Unfortunately, when we start our app we get the following crash from the Xojo framework.

Runtime Error
Please report what caused this error along with the information below.
Common/ObjectGlue.cpp: 147
Failure Condition: mClassPtr

As far as we can tell we have all of the required AMD64 libraries installed that Rosetta 2 / our app would need so it should just work.

Does anybody have information on what could be triggering the crash?

NOTE. I know Xojo compiles for ARM Linux but this project relies on a 3rd party library that does not have ARM Linux support (yet) so we were hoping to use Rosetta 2 in the meantime.

So you’re trying to use an x86 library from within an app built for ARM Linux? That’s not going to work. The platforms have to match.


The executable and all libraries are the Intel (AMD64) versions.

That note was to try and avoid somebody replying with “just compile your app for ARM Linux”. That, of course, would be the best solution but cannot be done until we have a ARM version of this library.

Uh… are you running an emulator in your ARM Linux VM?

1 Like

Rosetta 2

[Running Intel Binaries in Linux VMs with Rosetta | Apple Developer Documentation]

Yeah, but did you (or the emulation tool you are using) follow all of the instructions on the page you posted?

As far as we can tell, yes. We have tried several solutions which support this and we always end up in the same position.

Rosetta 2 is obviously working otherwise we wouldn’t have got this far as the error is from the Xojo framework.

It could be a misconfiguration somewhere but as far as we can tell, we have installed all of the required AMD64 system libs.

If we knew what the error actually meant I’m sure it would help us get this working.

I don’t really understand what you want to do. But have you tried the usual new Xojo project first?