Failed to locate Framework DLL

Suddenly one of the users of my app is complaining that it doesn’t run anymore

I checked and noticed that indeed the app does not start, and shows two error messages

1 - api-ms-crt-runtime dll missing
2 - Failed to locate Framework DLL

Here’s what I tried

I installed the 64 bit vc_redist.x64.exe that comes with Xojo
I installed this update
I copied all the windows runtime files (api-ms-win–xxxxxx) next to the app and I managed to get rid of the first message

Still the app won’t run, showing “Failed to locate Framework DLL”

It’s really strange since it was working a couple of days ago and he says nothing changed in that pc.

It’s a windows 8 64 bits machine.

Ideas ?

He’s wrong.

Where are the Xojo DLLs relative to the app?
Is he launching the app using a shortcut he created, or one generated by an installer? (If the working directory is not local to the dlls, you will see this message)

C’mon Jeff you know that nothing changed. Nothing ever does, except…

Now, on the more serious side. Is the app itself 32-bit despite the OS being 64-bit? if so, you need the 32-bit libraries.

The app is launched from shortcuts OR from the app icon. None works.

The app is 32 bits, the OS is 64.

The Xojo DLL’s are where they always were :slight_smile: inside APPNAME Libs folder, next to the executable

  1. Reinstall app
  2. Disable anti-virus
  3. Howl at moon

Which order you try them is up to you :slight_smile:

The 64bit DLLs don’t go there, and neither do the runtime support libs if you include them.
(likely doesn’t apply to you, just noting it for future searchers)

Also, try howling at the moon first. :stuck_out_tongue:

Its not a 64bit app, they are in the right place.

I tried so many things now I don’t know EXACTLY what I did to make it work… But I suspect, copying the 32 bit windows runtime files next to the app made it work. (something I didn’t try before)

Thanks folks for the support.

PS : I DID howl at the moon…


Roman, I think this is the second time I read someone that fixed the problem by copying the 32 bit runtime files next to the app.

Maybe some windows update (other program) block the Xojo app to find the runtime files.

@Alberto De Poo : Could be… I did try disabling Anti Virus… but I don’t think that changed anything.

Honestly… I have no idea why it suddenly stopped working…

I am not exactly sure what it means to “copy 32 bit runtime files” next to the application means. But I have a friend (in Canada while I am down here in the States) to whom I sent one of my programs and he gets a “failed to locate framwork dll” error message and cannot run the program.

He is not a sophisticated computer user. He uses Windows (Windows 10). I really only know the Mac universe. I have no easy access to a Windows computer.

I have no “commercial” interest in distributing my programs, but informal distribution has become more complicated. I can no longer just send a zip file with my program to my friend’s gmail account because gmail detects the executable within the zip file and for security reasons squashes it. So I zip the file and send it to my Dropbox or OneDrive and send him the link and have him do the download.

When I zip the Windows stuff, I am zipping a folder with assumes the name of the program (in my case ListTA). Within that folder there is the executable file (ListTA.exe) and two folders (ListTA Libs and ListTA Resources). I assumed that the recipient would simply unzip the file and end up with this folder (ListTA) and be able to run the program from that location without difficulty.

I have no problem with the Mac compiled program (which of course just appears as a single file)

But he does have difficulty and I am not sure what he or I should be doing to make it work.




are links to the file in question should anyone in the Windows world have the idle time to play with this and perhaps offer me advice as to what is going wrong with this “distribution”. Could he or Windows be taking the exe file out of the folder and moving it elsewhere and therefore making it not work? Or is there some other obvious “issue”? And where would these “32 bit runtime files” be lurking if that is part of the problem?

The program itself is “non-threatening”. Just a program to access Terminologia Anatomica medical terminology.

I’m not sure but I think you have to select the Include Windows Runtime DLL’s in Xojo:

Build Settings:

Build (change to ON, even if you build 64 bit):

In my 2017 R3, the “Include Windows Runtime” option is under “Advanced Build” section accessed via the “gear” icon.

Sheesh! Nice way to obfuscate the interface Xojo. Who dreams these things up?

I’m trying to replicate the issue here to see if I can figure out why its happening.

I just installed a fresh VM of windows 10 from here and ran your program from the dropbox link.

The application is maxing out the CPU but not showing me anything, I assume that isn’t the feature set of the app :wink:

I then tried the link from onedrive and it did the same thing.

If you are building for windows from the mac then I really can advise as I’ve never used this feature, I always build for windows in windows.

Just let me install the Windows Runtime Installer from the xojo extras folder and see if that kicks it into action, nope, that didn’t make a difference.

It might be worth putting in a bug ticket for that project, if your code is ok and its not just stuck in a loop somewhere I’d expect it to at least show the interface or crash if it wasn’t going to run.

Not much of a help I’m afraid, not even two steps forward and one step back.

I’m just going to fire up my old mac laptop and have a play around making builds to see what happens, I’ll let you know if I find anything.

Oh, I forgot to ask, what xojo version are you using Robert?
and does your friend have an antivirus program installed? if so what make and version?

Mac 10.13.2
Xojo 2017 v3
My friend has “Windows Defender” that tells him that the program is from an unknown source. But that is it.

This is the link to the Mac version

This is a link to the PC version with Include Windows Runtime as per Tanner Lee

Hmm odd, I can’t get it to run on windows 10 or windows 8.1, it just hangs and maxes out the CPU :frowning: It runs ok on my mac.

Would you be ok sending me a zip of the source (in a private PM) so I can run it in the IDE and see what the problem is?

Either that or put it into a private ticket on the feedback system so Xojo can take a look.

All I can suggest really, without being able to replicate the problem :frowning:

Just confirming Julian’s note that the app does start and hang a on Win10 VM. It shows in Task manager, pegging one of the CPUs, and memory use starts at 12 MB then shortly settles down to 2.6 MB.

Julian: Here is the actual Xojo program itself. I am not concerned about my code being “not private” for this project. Thanks for the time you have put into this so far. I hope it is not something “stupid” that I did.

Here is the binary version

Here is the Text version of the program (if needed for Windows folks)