Executable requires certain level of macOS

Hello all,

Yesterday my apps were built fine. Today at the Signing step it says
“Error signing application: Executable requires at least macOS 12.0, but is being run on macOS 11.6.7, and so is exiting.

the codesign_allocate helper tool cannot be found or used in …
… app/Contents/Frameworks/Shell.dylib”

Any ideas?


Move to MacOS 12?
The error message is quite explanatory…

No, I’m still using 10.13 without problems.

1 Like

I imagine the response is quite predictable too. Likely to be the same as mine would be.
The better question is ‘what is it in this build / signing process which demands MacOS12?’

1 Like

Having felt into traps like this, I imagine the answer is along the lines of “XCode changed the paths and features of its tools between versions, like it does often”. :man_shrugging:

I recall, when I first tried App Wrapper (and the notarisation in general), I was using an earlier OS version than the current one, so the most recent available XCode was itself too early to support App Wrapper’s (thus Apple’s) current method of wrapping (seeing messages like “Tool not found” and aborting). Figuring that out wasn’t straightforward.
And Robert’s message sounds like my experience.


I recall a previous error when I was trying to upgrade to Xcode 13.4.1. This version comes up with this error:

Xojo error:

And therein lies the primary justification for licensing App Wrapper – I’d rather spend my time chasing my own bugs and features instead of all the rabbit holes Apple doles out.


Hello all,

I got it fixed!

Rebuilding a project with Xcode 13.2.1, the current version, puts the search back to its place,
so now Xojo builds fine.


Exactly. That’s a big time saver.


1 Like