ExcelWriter in Windows

I have a desktop project on macOS with an export button that creates a spreadsheet with Einhugur’s ExcelWriter plugin. When I run the project on macOS it all works fine. When I debug under Windows I get the error message below (but the app still runs). If I delete the button, the error message no longer appears in Windows. It only appears on launch, not when I click the button.

I am running the latest Xojo 2019R2 with the latest Einhugur ExcelWriter 1.7 and #TypeLib.xojo_plugin 9.3.2.
I assume it has something to do with the 2019R2 DateTime changes (I have not updated this project to API 2), but why does it affect Windows and not macOS, and what is the solution?

You should contact Björn, because here it works just fine on macOS and Windows using the same PlugIn Versions. But i am not 100% sure, if i use API1 or 2 atm.

Thanks. I searched the forum first for an answer, but found none. Sometimes the forum is faster when you need an answer urgently.

Using the ‘TypeLib for Xojo 2017r2 or newer (GTK3)’ solved the issue .

I think there is issue there though, when checking the build Macro’s then I think there may be issue with Windows and Linux APIv2 version.

Which I will try to push out fix for at end of the week.