Excel Application

I am still converting older RS Applications to Xojo - 2013r2.

I have one application that opens and manipulates a couple of Excel workbooks. The application will not compile in Xojo.

The code:
“Dim excel As New ExcelApplication”
yields the “There is no class with this name” error

So, I tried the sample in the Xojo documentation for “ExcelApplication” and also get the same compilation error.

What am I missing ?

Try copying the “MSOfficeAutomation.rbx” file from

{INSTALL}\Extras\Office Automation

Close and re-open the Xojo IDE. That should do the trick.

Thanks, that worked fine !!!

I must admit that I am really struggling with this transition from RS to Xojo.

Is there such a thing as a “Guide to Transitioning from RS to Xojo” ?

There is the {INSTALL}\Documentation\UpgradeGuide.pdf manual.

I haven’t read it though, so not sure how it covers the different aspects of migrating from RS to Xojo. I suppose the forums are going to be the best place to post questions.