Since I’ve upgraded to 19r1 my app is crashing intermittently as windows open with EXC_BAD_INSTRUCTION

I’ve tried to get to root cause for a while now, with no luck. Does anyone know a way of figuring out what might be causing this?

Thanks in advance


Please read the crash report.
Probably a warning about some entitlement, code signing or info.plist entry.

By using newer Xojo, you use a newer Mac SDK.

Thanks Christian. I’ve tried to, but can’t see anything object/code that could be from my projec. Is this something you could help with? Thanks again

Linked Crash Report

That looks rather thin:

[quote]Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: 0x0000000000000001, 0x0000000000000000

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [28362]

Application Specific Information:
*** __CFTypeCollectionRelease() called with NULL; likely a collection has been corrupted ***

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.apple.CoreFoundation 0x9379bb5f __CFTypeCollectionRelease + 54
1 com.apple.CoreFoundation 0x9379bad8 __CFBasicHashDrain + 429
2 com.apple.CoreFoundation 0x938c1dc3 _CFRelease + 241
3 libobjc.A.dylib 0xa6c1b48e (anonymous namespace)::AutoreleasePoolPage::pop(void*) + 720
4 com.apple.CoreFoundation 0x9379a314 _CFAutoreleasePoolPop + 24
5 com.apple.Foundation 0x9513b124 -[NSAutoreleasePool drain] + 120
6 com.apple.AppKit 0x914a2bb0 -[NSApplication run] + 924
7 com.xojo.XojoFramework 0x056d7fae mainloop() + 46
8 com.xojo.XojoFramework 0x056d6118 RuntimeRun + 49
9 com.obatics 0x0022fdf8 REALbasic._RuntimeRun + 34
10 com.obatics 0x0460b696 _Main + 295
11 com.obatics 0x045ef105 main + 36
12 com.obatics 0x04641b28 start + 53[/quote]

What are you doing when the window opens?

Hi Beatrix. Thanks for taking the time. A lot of things really. The window is a settings with a lot of objects most of which are sub-classed. It’s also not specific to the one window (though, the settings window is the most effected, probably as it’s carries the most objects)

That’s the kind of crashes I keep having in iClip - I get daily similar crash reports from my customers. It started when building iClip with RB 2019r1.1 - before I used a 2017 version, I think.

The crash stacks all vary a bit, but all have in common that they happen when releasing objects in the Autorelease Pool.

Most often it either says:


Apparently, this often happens after closing a window.

Can anyone confirm who had these crashes that they stopped occuring in a later Xojo version?

I haven’t experienced since r1.1 and still working with the same project

You mean 2019r1.1? I am using the same, building for 64 bit, and constantly see these crashes. Damn.

Yes, 2019r1.1, but I haven’t seen the problem since I upgraded from that. I did see the crash in 2019r1.1

Ah, you mean that Xojo versions AFTER 19r1.1 did not show this issue any more?

Yes, but obviously upgrading is not a guarantee it will solve your problem

Right. I only change the Xojo version if there’s a serious issue with one - and I don’t change it unless I have to, because it’s more likely to run into more (new) problems. Like with this one, which didn’t happen in earlier Xojo versions.

I go by the rule (mainly for software I see, where I don’t need extra drama): Never change a working system unless you have to.

I’d start by asking what declares or plugins you’re using in that window.

I’ve run into this many a time with my declares, almost always it’s because of something I’ve done wrong. Especially any GUI declares that can re-register a view with another view or view controller.