Error "undefined symbols for architecture x86_64"

Why do I get the above error for a project that doesn’t have any problems? Got it just now on my iMac and had it a couple of days ago on the MacBook Air. A Xojo restart “fixes” the problem. But it’s annoying. Any idea what might cause the error message?

Xojo 2018r3, macOS High Sierra + Mojave.

Did you get a test project to make this?
Any log messages in console in Xojo or
Or running Xojo from terminal and look for messages in Terminal.

The error happens out of the blue. After restarting Xojo everything works again.

I can’t run Xojo from the Terminal all the time. The next time the error happens I’ll check the Console.

It happened to me too a couple of times. As far as I recall, it happened when I run the debugger after having inserted a new menu handler in an old project.

Just run into the same problem after I changed the name of a menuitem. (2019r1). (Just for the record)

basically thats the compiler not finding or linking in one of the cached compiled items and so the symbols in there (methods, global variables, etc that are exposed to the other parts of your app) arent found and so the compiler complains

Is this only happening during a debug RUN ? or when you BUILD ?
Either way clearing caches should reset everything so it all gets recompiled and linked

And if not the compiler guy at Xojo should look into it

Please file a Feedback report so we can try to reproduce it and investigate further.

I should have mentioned that restarting Xojo solved my problem. I didn’t try to build (it was a Run). If it happens again I’ll try to build as well.

If it repeats I’ll file a report. Thanks.

That usually would since all the caches would get dumped and cleared

There are already reports marked verified for this particular issue


a search for (including the quotes) “undefined symbols for architecture” turns up many more closed as not reproducible