Error signing... detritus not allowed

After Updating to macOS 14 and Xcode 15, I get the following error.

Error signing application:/Users/… resource fork, Finder information, or similar detritus not allowed

when I want to debug an application (Running within the IDE with Command-R). The error don’t appear always, sometimes it works fine. And with the next run the error appears again.

I tried to remove the attributes with xattr, but there seems to be no way to add a script between building and signing. I tried to add a script, but the error appears before the script was executed.

I tried it with the official version 2023 r2 and the latest beta.

You should be able to sequence build steps by dragging them in any order you desire.

Screen Shot 2023-09-27 at 08.25.44

In this example, you can see a step happens before build does, steps between build and sign, and steps after signing.

Perhaps one of your CopyFiles steps is carrying over one of these detritus files? You might even be able to fix the root of the problem by removing the problem from the source file / folder rather than solve it in a build step.

1 Like


thank I tried this. but the Print from the script appeared after the signing error.

But I also saw the the xattr command didn’t solved the problem when I tried the script for building the productive version.

Set your script steps to “none”. Then add them back one by one until you get the detritus message again.

You will get errors, including the one you quoted, if you haven’t opened the new version of Xcode and accepted the license agreement. Have you done that?

I have no script between Building and signing. I tried to put one for the xattr command.

Yes Xcode was active - I compiled some apps with it before the problem occurred with Xojo.

When I show me the files with “xattr -lr”, all are from the Xojo framework.

… and it happens not always. Sometimes it works and without changing something i get the error.

Do you use iCloud? For example, are your projects (and thus your debug builds) on iCloud? Nowadays the Desktop and Document folders are in iCloud by default. If they are, can you try moving the project folder out of iCloud (for example, into a folder in the root of your user folder) and run again?

1 Like


thank you very much. Yes Xojo and the projects were in the iCloud. I moved first Xojo into the application folder - but this didn’t work. After moving the project folder into der User folder it works.

1 Like

This is a big little problem… I hope Apple will fix this problem soon. For now I’ll copy the project on the desktop while working. Using icloud is very useful for me (MacMini at office and MacBook Pro when I’m outside).
I know is not recomended, but it’s useful (when it works)

1 Like

Don’t forget that the Desktop folder is now also optionally in iCloud.

1 Like

You can stop iCloud syncing by renaming the parent folder with the extension .nosync if necessary.


It is a very nice idea

Thanks for the tips. I don’t need the iCloud for transferring data between two systems. But I like to have an external backup. TimeMachine also stores the data. But in the case for example a fire both will be destroyed.

for me, I’ll wait this weekend and check if there is a correction. If not I have to change my scripts for the new location. And I will include a copy function for a backup into iCloud.

That’s the reason why I have an external hard disk, TimeMachine AND Acronis.


I had the same issue on Mac Desktop. All I did was put in my developer account email address into the signing step of the build and it fixed itself.
I had never used that before, always relying on App Wrapper.

However I’m having the same issue on iOS right now, and nothing I do seems to fix it.
Feel like I’m going bonkers…

I tried it today with the mai-dress - and it worked. I also used it before, because I use own scripts for building. And there is a problem after inserting the mail-address. But there I can check it.

Thank you.

Thanks Gavin for that solution. But about the other solution… how do you put your email address in the signing “step” of the build? i see the Sign settings for iOS, but no spot there to put my email address.
Is this 2nd solution the way it should be done? Is it an Apple bug or is Xojo supposed to use the email address?
Thanks for any help you can offer.