Error Signing Application for ARM64 in Release 2020r2

After a “Universal” build produced no app or any diagnostics, I tried to generate an ARM-64 bit app.
An app was produced but I got this errr:

Error signing application: /Users/robin/Documents/MyAccounts/Builds - Accounts 7.2.9/macOS ARM 64 bit/ No such file or directory

Transferring the app to a new Mac mini gives me this result "You do not have permissions to open the application …

Any ideas on how I can fix this or get a reason why the "Universal "didn’t produce an app?

First, try just building an x86-64 app and see if you get any errors there.

It would also be helpful to know what version of macOS you are working on and if you have any versions of Xcode installed.

ARM build apps needs to be signed.
If you did not codesign the app yet, you need to do this.
You can do a quick adhoc signing by doing this on the AS device:

xattr -cr pathtoappfile
codesign -s - pathtoappfile

You shouldn’t have to do this though. The IDE is trying to sign it itself.

Compiling x86-64 works fine except the executable app is located in the source directory. And if there is a Builds - … directory, it is removed. And the executable runs fine on MacOS

Sorry, I’m using MacOS 11.0.1 on an iMac and have Xcode 12 installed

This saga reminds me of similar problems with directories that we encounter many years ago (:wink:

I have also seen this error today (once) when messing around with enabling/disabling build folders.

It also was building, but not replacing the app on completion (when build folders was disabled). Imma take a break, incase me trying to find a work around for build script system (with UB) has only made things worse.

16" 10.15.5.

This has worked (thank you) with another curious result - the app reports that the MacOS it is running on is 11.0.1 which is correct.

The same app produced by compiling for X86 and running under Rosetta reports that the MacOS is 10.16.0

Sam’s comment made me look for enabling/disabling build folders (in the shared settings which I would not considered) and the switch was off.

Enabling build folders now produces a Universal app (wow it has to work at that) which, when moved to the Mac mini, works fine.

Thank you one and all for your help.


1 Like

Which believe it or not is correct.

Glad I could sorta help. I’ve experienced funny stuff with Build Folders disabled in the past.

Well - yes and no.
The reason behind this effect is that the arm64 build is linked against the Big Sur SDK. Whereas the x86-64 part is still linked against an older macOS SDK.

Applications linked against the newest macOS SDK will report 11.0, “older applications” (not in the meaning: time of build, but linked against an older SDK) will report 10.16.

And that’s just one of the differences you get in runtime behavior…!
It’s a bit silly to build a Universal binary in which the two included targets are linked agains different SDK’s. One has to know the differences and deal with it. Maybe not what the “average Xojo developer” expects.

For sure you need to test both x86-64 and arm64 independently. Don’t assume the application will behave the same on Big Sur (Intel / M1).

Someone should probably start an own Thread with “(Un)expected differences in Runtime behavior on Big Sur (Intel | M1)”… I think to remember differences in Toolbar, some Window/Drawing-things, …

Has someone reported that in Feedback…?
Xojo has already done some changes with <>, but they need to consider this “build folders setting” situation, too.

I thought I’d already done that for my blog, comparing 10.16 to 11.0… Can’t find it now, if someone really wants to see, I can boot into BS and create an updated GUI cheat sheet.

I have a related article scheduled for my blog this weekend.

As you know… Xojo throws an error on my MBP M1 when doing a debug run. :frowning:

Build folders (shared build settings) is this on or off?

I was getting an error when trying to build just an ARM app (A Xojo code signing issue), and toggling this option appeared to fix it for me and @Robin_Harrington.

Oh debug runs… It probably doesn’t apply there, but give it a shot and see if it makes any difference.

Where can I find this option in Xojo?

In the “Navigator” sidebar at the top of the build options, which are listed towards the bottom of the sidebar. I think it’s just called “Shared”. Don’t have Xojo on this machine, so I can’t check, sorry.

I’m blind. I can’t find it. :slight_smile:

I think Sam is talking about Debug - Destination:

No, it’s “Use Builds Folder” in the section you chopped out :slight_smile:

1 Like

It’s enabled here. Still getting the same error.

Sorry about that, I read that as a Build option and I think @ChristopheDV is having problems with debug run, don’t know if changing the Debug destination will help. Maybe he is having problems with debug and build.