Error Loading Xojo after 2.1

Windows 10 Pro:

Uninstalled 2019r2.0 (that was probably a mistake)
Installed 2019r2.1
When Xojo loads I get about 10 error messages - see attached sample…

Even when I load 2019r1 (I think it’s actually 2019r1.1) I get the same errors now. This used to work fine.

After it loads Xojo appears normal, but I haven’t tried to do anything yet.

Reinstalled 2019r2.1, problem persists.

Please advise.


old plugins ?

remove the plugins one by one and see if you get to a point they load

No, there are no plugins other than what comes with Xojo itself.

Any other ideas?


This morning I tried relaunching 2019r2.1 & 2019r1.1 and no error message. All works normally. I haven’t even rebooted my machine.

Now I remember something else. Yesterday my screen saver wasn’t kicking in after the usual 7-min inactivity pause I have it set to. That’s usually related to a memory consumption issue. The screensaver is back and Xojo now loads normally.

I’ve seen similar issues in Windows 10 over the past few days. It appears that the NTP functionality is a bit hosed and the system clock is getting twisted. I keep having to go back to the Windows settings and turning auto timezone off and back on. It also affects any version control apps you use.

Yeah, it happened again yesterday, then subsequently not. Thanks for the confirmation.