Error launching Xojo 2016r1: PowerPC no longer supported ??


I just downloaded Xojo 2016r1 OS X version.
I’m getting an error when starting Xojo: PowerPc applications are no longer supported.

It’s not a Xojo application, it’s Xojo IDE itself !

Tried to download again but still get the error when launching Xojo.

Running OS X El Capitan (10.11.4)

Any idea ?

Thanks !

Taken from (2010):

Try to download again. Perhaps your download was corrupted. I’ve seen this a couple of times.

If he’s running El Cap he can’t be using PPC, right? :slight_smile:
Something else must be going on.

Try a reboot and reinstall, my friend had this problem when I told him about Xojo a few weeks ago.

If you can’t get it working, let me know and I’ll message him to find out if he did anything else to get it working.

Long shot:

How are you launching it?
Do you have an old version lying around and its being launched by you double clicking a project?

Thanks for your answers, but, just to clarify:

  • I know pretty well that PowerPC is not supported but it’s the Xojo IDE which is not launching
  • I’m not running a PowerPC version of El Capitan ! :wink:
  • I’m not loading an old project, I just launch Xojo from the application folder.
  • I tried downloading once yesterday, twice today, all files are coming from the same url and have same size

I’ll try rebooting later today.

Maybe it would be interesting to have a MD5 checksum displayed on Xojo download page …

I’ll keep you posted later on.

I had the same kind of message pop up a couple times along the years with other programs than Xojo. In every instance re-downloading did the trick.

It would be interesting to compress the offending version and send to Xojo for analysis. Maybe they will find out what happened.

Maybe this will help:

Hi @Sascha S,

This did the trick:

Maybe this will help: 

Moving to desktop, launching OK, moved back to Application folder, launching OK.

Many thanks !


Solution: Download the Mavericks installer from the App Store, use Disk Utility to create a USB boot drive. Boot from said drive, do a clean install of Mavericks.

While I jest, I wouldn’t actually recommend that you do, there’s a ton of bugs in El Cap and the best way to make sure your software is compatible is to develop on it :frowning: