Error I don't understand

MAC OSX 10.12.6; Xojo 2017 r2.1, Xojo 2016 r3.0

Opened project this morning and am suddenly getting error of:

Can’t find type with this name

Made NO CHANGES to code, just tried to compile.

I’ve cleared cache, rebooted, tried with older IDE.

I have no clue what this is or how to fix it.

Any / all assistance appreciated.

TIA, Tony

Probably a typo in the property or your code

Did you try searching your code for that iGrpahicsExporter?

Are you using Newer plugins?

Do you have Einhugur plugins installed?

I removed the latest version of the Einhugur graphics plugin and error gone.

Thanks @shao sean

I am guessing you had one of the GraphicsFormats Legacy plugins installed.

Having GraphicsFormats Console requires GraphicsFormats Legacy also. Else you would get this error. Both of those plugins are legacy now though but are included with the new plugin for people that still have old projects to migrate.

With that said the new one that is not in the Legacy directory does not use IGraphicsExporter. And works both on console and Desktop.