Error I can't explain...

I get an error on these two lines. Why is that? If i change the settings to specific numbers in the code, then this specific error will be solved but then other errors occur later in the code…

These things used to work! But also, I’m lost in the Xojo upgrades… maybe something has changed? I was the case in previous errors. (2014r1. Not the very latest but sort of a late version.)

What is the error you get?

Maybe because you are assingning a Double to an Integer?


what is error message?

Probably not double vs. integer.

KAT could have no implicit instance for example.

From the looks of the image you’re accessing the UI from a Thread. Don’t do that. You need to take all the UI referenced control data & copy it to properties before running your thread and if you need to update the UI from your thread you need to use a timer to do the update.

Yes!! There it is!!
I have already solved this… in a similar project… somewhere…! :slight_smile:

Thank you!

Wayne, I’m impressed. That’s really good “looking at the whole code” rather than being distracated by the Double->Int16 thing.

Good catch!

Thanks Garth, Jakob’s image made the issue very clear to me, but sometimes it takes a different set of eyes to see the obvious - I know it’s happened to me more than once.