DynaPDFMBS - untrappable crash when setting font

I have one customer for whom any attempt to set a font in a DynaPDFMBS instance causes an immediate app shutdown.
If I dont set a font, it all works.
I have tried Arial, Helvetica, Times New Roman to no avail.
I have tried having the app run as Administrator.
No other people have reported the same issue, and I sell many copies of the app per month.

Code that seems to be related:

call pdf.SetFontSelMode(pdf.ksmFamilyName)

Inside DynaPDFGraphicsMBS:

call pdf.SetFont(myFontname, Style, myTextSize, true, pdf.kcp1252) //myfontname is a string and defaults to 'Arial' //myTextSize is an integer

At other places:

call pdf.SetFontAnsi userSelectedFontName, pdf.kfsNormal, 24 , true, pdf.kcp1252

Any ideas I may have overlooked?

You can reproduce this crash with current version?

Is that an ancient DynaPDF version?

Can we have a crash report?
e.g. as link to download?

I cannot recreate it by any method.
This is one customer among many hundreds, and there is no crash report.
App just disappears…( I had to add logging line by line to work out where the problem lay)

A mystery for ever then. :frowning:
Don’t you love it when there is just one machine that doesn’t work…?

Maybe they have a broken font file installed?

Or duplicate fonts with same name?

All I can tease out of them is:
Arial , and all the other names we tried , work in every other app.
Arial doesn’t appear twice in font lists.
The machine is running in American English.
It’s Windows 10 and quite a recent machine.

No console message, no onscreen messages, no blue screen of death, just instant and untrappable vanishing.

You would need to install a debugger like Visual Studio to jump into debugger.