.dSYM file not being created during build

When I build my app, I am not getting any errors, but I am not getting the .dSYM file created, and I get a “No code signature found” error if I try to install it onto a device.

Has anyone else had this issue, and what do you do about it?

After trying for half the day to get an ios app I’m working on onto my phone for testing, I decided to test a blank new project. It worked perfect, and installed onto my phone without issue. But then I realized, my app hasn’t been creating a .dSYM when I build it, but the app appears to be built otherwise. I have not gotten any build errors.

Do you have a team set in the build settings?

Sorry, yes. I should have specified. I do have the team specified in the build settings. I’ve gone through 100 different certificates and provisioning profiles thinking I had something wrong there, but the issue seems to be the specific app not compiling properly - but I am not getting any errors.

Well, I figured it out, but I’m still not sure what the issue was. I created a new project, and copied over all my views, modules, classes, etc to it, and it worked fine.