Dropping text onto the Method name display changes method name?

I just accidentally dropped some selected tape onto a method’s title area. My method name then changed from the assigned name to G (the first letter of the dropped text). The MethodName popupmenu then also changed to G. I tried undoing and it does not undo.

Should the drop be accepted? If so, I presume that what I’ve witnessed is a bug?

2017r3, Windows 10

I tried 2017r2.1 and r3, macOS 10.10.5 and did not see this

  • created a new project

  • added a method to the default window

  • opened TextEdit, typed some random word

  • selected word in TextEdit and dragged it to the method name in the listbox, no change

  • dragged the word, from TextEdit, to the method name at the top of the script editor, no change

  • added a parameter to the method and repeated the above tests, no change

  • changed the method scope and repeated the above tests for each scope, no change

So if this is an issue, it might just be Windows only (don’t have a Windows machine to test on though)

I can only get it to happen on Windows and not every time … love those :S

When I go back to work (not until the weekend though) I’ll install Xojo 2017r3 on a Windows 10 machine and give it whirl and see if I can duplicate it… Are the methods part of a class/control or a module or doesn’t matter? Do they have parameters? If so, does it seem to make a difference on the number of parameters? Just asking a bunch of questions so I have a starting ground, other than dragging text for hours on end :wink: Also, the text you’re dropping, where was it dragged from? Inside of Xojo, an external program or doesn’t matter? Anything else you can think of, just post it in here (hopefully someone else can chime in so you don’t have to wait until the weekend to find out if you’re crazy or not :wink: )

The IDE when running on Windows allows the pasting of a complete method into the Method Name field. The IDE will then parse this to create a new method, so maybe expected behavior?

So does the Mac version, I believe that is a feature of the IDE… When Time mentioned the “title area” I was thinking the area above the script editor, as he mentions later “The MethodName popupmenu then also changed” which sounds like the area you’re speaking of, but I’ll leave this to Tim to correct us… Post a screen shot of the area you’re talking about Tim, seeing as there is some confusion now (I’m mostly confused so no surprise there, but Wayne seems to have his stuff together :wink: )

Shao is correct - this area:

It is odd, though. With a new, fresh project, when I drag over that area in the IDE, I get the “not” icon. I’m still checking other scenarios …