Dreaded No Profiles Problem

Using Xcode 10 and Xojo 2018.4.

On building for store I get the “No profiles for … were found.” error.

Saturday, all of a sudden, I couldn’t even build to install locally. I think a certificate expired. I set up a new certificate, and did something suggested in another Forum discussion, and that problem was resolved.

I have downloaded and installed a profile for the app in question.


Is there any way to see what profiles are on the computer these days? In previous versions of Xcode, they were visible there or in a folder in the Library. I ask because it might be useful to get rid of all the old stuff.

Is there current info on how to deal with this?


Problem solved.

  1. How to locate Provisioning Profiles: They are in ~/Library/MobileDevice/Provisioning Profiles. There are two things about this: First, note that this is not the Library folder that directly visible on the drive. It’s the one in your user folder. Second, it’s invisible. To make things visible, type Cmd-Shift-. (That’s Command Shift Period) in the Finder. You’ll know it worked because you’ll see a bunch of new folder items. To hide the invisible items, type Cmd-Shift-. again.

  2. What I did:

I found the Provisioning Profiles and removed them from the folder (see above). I also checked in Keychain Access and removed an out of date certificate.

Then, to the Apple site (Account) to generate a new Development profile (actually used my Xojo wildcard for this) and a new Distribution profile. Downloaded and installed same.

Things appear to be okay now.

Hope this helps someone.