Drag and Drop only works in debug

Windows XOJO 2018 R1.1
When I drag and drop a file to a Groupbox while in debug mode it is successful ie. the icon appears while I hover and the “move” text appears.
In the complied version (x64) I only get the no-go circle with the diagonal line and nothing happens when dropped.
I have been told by customers it works on 32 bit machines so is it something to do with differences between the IDE Run and the 64 bit compile?
PS. Works perfectly on Mac.

If you are running your windows app with elevated security you wont be able to drag from explorer onto your app as the security levels are mismatched.

You can check that you’ve not turned this on by accident in 64bit by going into Build Settings>Windows>Right Nav Gear Icon>Security>Privileges and ensure that it’s set to User.

If the security level is increased at runtime by the client using other methods there’s no way around it.

Well technically there is, you detect the elevation and relaunch the app without the elevation then close down the elevated edition.

I think you’re right. I’ve got the app running on my computer and at some point I’ve set Compatibility to Run as Administrator, probably to sort out a bug, I don’t remember.
Now it has the shield on the icon in the START menu.
Trouble is I can’t get it to NOT run as Administrator. I’ve removed Run As Administrator from Properties and even completely uninstalled and re-installed.
I still get the Shield icon and the UAC window still prompts me when I start the program. Any ideas on how to do this?

Did you check the setting in the left Nav of the Xojo IDE under:

Build Settings>Windows>Right Nav Gear Icon>Security>Privileges

and made sure its set to User? Then rebuilt the app?

[quote] JulianS - Pre-Release Testers, Xojo Pro UK

Did you check the setting in the left Nav of the Xojo IDE under:

Build Settings>Windows>Right Nav Gear Icon>Security>Privileges

and made sure its set to User? Then rebuilt the app?[/quote]

All fixed, thank you Julian so much.
It was set to HIGHEST AVAILABLE. Changed to USER and now drag and drop from Explorer works fine.

[quote=395188:@JulianS]Did you check the setting in the left Nav of the Xojo IDE under:

Build Settings>Windows>Right Nav Gear Icon>Security>Privileges

and made sure its set to User? Then rebuilt the app?[/quote]

I’m running Xojo 2018, and I don’t see the Security>Privileges options. In the Build gear icon, the only option is entering the Name. Are these other options available only on the Windows version of the IDE? Or am I looking in the wrong place? I’m looking under Build Settings, the Windows checkbox item, and the first build step under that is the one with the icon.

John, change your target to x86 64-bit, then additional options will be shown in the gear tab: Supported Versions, Privileges.

Also, it’s the gear icon in the Inspector panel.

Yuppers, it only shows if you’re building for 64bit. Let me know if you can’t find it still John and I’ll make a little video.