Drag an drop a document on the app's icon

Dragging and dropping a file (or several files) onto my app’s icon *** in the Dock *** does work, whereas it would not on my (unopened) app’s icon *** in a Finder window ***. What am I missing ? My app’s Events Handlers include OpenDocument (which is the reason why drag and drop works for my app’s icon in the Dock). FileTypes are defined. I am using macOS 10.14.6 and Xojo 2023r4. I don’t encounter the problem with my (very) old RealSudio version of my app.

Please don’t do an issue in the tracker if you have a simple problem.

Make an example project and upload it for us to check.

1 Like

Too late, already done !

No example project/app was shared there.


I’m sure Xojo staff will ask for a sample project when they review the case.

Edit: or not, and ask to send email to support.
If OP can provide more information and a sample project, someone will be able to provide more ideas.

1 Like

The issue link returns a 404 Error now…

Solved by myself. It had to do with the FileTypes elements. The bug was solved after I selected “File type is unique to this app” for the file type specific to my app. Anyway, thank you to all those who answered.

IMO, it’s still weird that it worked from the Dock icon but not from the Finder’s icon. Both should rely on LaunchServices and behave the same.

1 Like

True. But fortunately solved. Merci Arnaud.

1 Like