Download - Working Chromium WebKit .ocx Plugin for xojo


regarding to this post:

here a (the) working chromium based .ocx plugin. Its mostly the same as the integrated xojo webkit, but it didnt freeze if you drag the window or other GUI-elements… But there are some other bugs.

If you want to display a website maybe an animation or something else, which shouldnt freeze while using the GUI and will need a better browser than IE, this .ocx is the right for you.

Orginally this .ocx where programmed for using in Visual Basic 6.0. I had to delete and fix some stuff. Not all control functions will work properly. For example if you use the javascript execute command, it works fine if you are using only one of these controls, if you are using two or more, the javascript execution command will always be send to the last added control. I dont know why. Also some other commands will not work properly or completly / producing error. I didn’t tested it yet.

But at least the most usefull commands like OpenURL, Refresh, Reload & more are working properly.

If you want to use the Xojo WebKit Browser combined with the .ocx Chromium WebKit Browser, Xojo will crash - Try to avoid it. The native browser is working.

I created an .zip file which includes the xojo projekt file (it will load a form with the included .ocx), the plugin itself and a batch file, which will register the .ocx file. Without registering the .ocx file, xojo can’t load (find) the .ocx file.


First extract the .zip file
run the “Register.bat” as admin (right click -> run as admin)
Open the project “WebKit_OCX.xojo_binary_project”
run the project and have fun

The original file is open source, use at own risk.

If someone want to fix bugs, than you are welcome

Thanks for posting this!
I am pulling it down now and will test it with some of our projects.
I am always on the lookout for better ways to display local HTML content as neither the Native nor WebKit HTMLViewer do everything we need. (The WebKit version is close, but I wish it could play .mp3 and .mp4 files.)

[quote=245663:@peter fricke]First extract the .zip file
run the “Register.bat” as admin (right click -> run as admin)
Open the project “WebKit_OCX.xojo_binary_project”
run the project and have fun

Problem running register.bat on Windows 10 :

The command-flag "-" is not valid. Please review the command usage and try again.

I suspected a path issue, so I went into Xojo_Chromium_OCX\WebKit_OCX\DLLs and directly typed :

regsvr32 WebKitX.ocx

It works fine when running the Command Line as administrator. The project also runs well.

Obviously it is only Chrome 25 :

Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.152 Safari/537.22

Not very much more advanced than current Xojo Webkit which is 18.

It is too bad the ocx cannot support the latest version of Chromium which is 44.0.2403.157

Also, I had hoped that like Chrome the ocx could open PDF files. Unfortunately, it is not the case.

I just tested the batch file on Windows 7, maybe the path command doesn’t work on Windows 10.

yes you are right, Version 25 isn’t that new. But it is still an advantage compared to the integrated xojo WebKit Renderer. I tried to visit some websites with the xojo WebKit renderer, and they where completly blocked… the website says “Please update your browser”. I also tried the .ocx Webkit (V25) and the Site was working perfectly.

The project uses the “Chromium Embedded Framework” Files “CEF1”

Wiki says, CEF1 is no longer developed.

The creater of the .ocx ActiveX Plugin says, he also tries to make a CEF3 ActiveX, but I dont know if he already retired his project…

Hi, I am WebKitX author. We have a CEF3 version available that we would like someone to let us know if it is compatible with xojo. You can download it from

WebKitX ActiveX has error: “failed to read type library”
Sounds like an old, repeating error from the ancient days of development…

Any solution?