Document window slightly under menu in Big Sur

My document windows appear to open ever so slightly under the menu bar in Big Sur.
Is this a ‘thing’?

Anyone else see this?

As far as I remember the menubar has a different height in BS.

It’s the width of the window’s title bar that is thicker. It’s a thing. You have to add a check for Big Sur in the Open event of the window to move it down a bit. Should file a bug so Xojo can do this automatically, but haven’t got around to it since it is easy to workaround.

a bug report already exists. Please don’t file again.

1 Like

How are you setting the window position?

IIRC and window.left are “content” positions. With declares you can get the Chrome height and use that to calculate the… or…

Use Window.Bounds to set the position of a window as that is using the frame rect and not the content rect.

He’s not. It’s the default window position in Xojo. Not saying it’s right, just that it is right now.

Oh… <thinks for a while/>…

Set the “Default Location” to “Main Screen” or “Parent Window Screen”.

I usually have it as ‘Staggered’
I’ll give this a try.

If you still want staggering, you can do this yourself. So if a window is already open (or type of window) you read and window.left, then set the new window.left to the those values + an adjustment.