Dock menu Quit doesn't Quit

Selecting “Quit” from my apps Dock Menu no longer Quits. The other choices, “Hide”, “Show All Windows” still work, as does Selecting Quit from the MenuBar.

This started after adding menuitem “Quit Without Saving” to the MenuBar. I made it a QuitMenuItem at first but it didn’t appear next to the real Quit so I returned it’s super to just MenuItem and left it in the File menu for now.

I’ve tried toggling the real Quits super to MenuItem then back to QuitMenuItem with no affect. Also, the real Quits menuhandler isn’t implemented if that matters.

I’ve tried replicating the behavior in a new project but can’t. I know the MenuBars Quit item is different than the Docks one but this started after fiddling with QuitMenuItem, and if I go to the project before fiddling with that then the Docks Quit works fine.

Any ideas?

[obligatory HIG statement about having multiple quit menu items, and about having quit under file instead of $APP]

Do you modify the dock menu in any way? I can’t imagine why fiddling with the MenuBar would affect the Dock menu; and to further that thought DockItem only lets you change the icon, not it’s menu… hmm.

No. I’ve used declares before to do that but this is just the standard, default, unmolested Xojo dock menu.



Tim, you got me looking a little closer at my code and found App.CancelClose isn’t being called but App.HandleAppleEvent is.

Wait, I implemented HandleAppleEvent… and poorly. Edited to return false and now Quitting works! Thanks.

You’re welcome!
I’m glad I could… help?