Disabled StyledText on TextArea

Any way to prevent styled text from being pasted into a TextArea (Mac/PC)?

Override paste somehow?

Under the Inspector, just turn the “Styled” to Off

Doesn’t turning it off only work on Linux?

It works for MacOS

The documentation of the Clipboard class has an example for pasting (unstyled?) text from the clipboard. I cannot test it now, but maybe this is what you are looking for.

What about using a TextField (set the Multilines property ON) ?

It looks like as @Edwin Lau said, you can just turn off the property. Turns out the documentation is incorrect.

You are correct. I’ve updated the TextArea.Styled and TextArea.StyledText pages.

Thanks @Paul Lefebvre. BTW, is there a preferred way to notify you of suggested documentation changes?

Use the Feedback application.

For small typos and mistakes that are easily fixed, a forum PM or email is fine, but Feedback is also great as there’s no chance something will get missed.