Did r3 change plug-ins?

I’m using MBS Chart Director, and the plug-in is not loading in R3 (yes, I copied into plug-ins directory)

Do you use MBS Xojo Plugins in version 9.5 or newer?

Yes, I’m using the latest version you posted yesterday. (196p1)

I had a problem with the cache in R3. After deleting the cache all the MBS plugins loaded fine.

Hi Betrix, just tried clearing cache on OSX. Unfortunately did not solve problem. Christian - I’ve also tried 195 with r3- same problem.

Does Xojo load any plugins?
If Xojo is in quarantine, it won’t be able to load them.

You’re right, r3 is not loading any plugins.

Execute this command in a Terminal:

sudo xattr -cr /Applications/Xojo\\ 2019\\ Release\\ 3

However, if you drug the Xojo folder from the DMG to Applications via Finder, that SHOULD have been taken care of automatically.

Wow. You’re both right, Xojo was quarantined.

The following command returned this:

xattr xojo.app
com.apple.quarantine

This fixed it.

xattr -d com.apple.quarantine xojo.app

As for installation: I simply opened the r3 DMG and dragged to Applications.

This concerns 10.14.6 Mojave (EDIT: I installed the security update 2019-002 released today - prior to the r3 update).

Did you wait for the DMG to verify? If you skip that step then the app will be quarrantined. I learned this the hard way…

Michael - I did wait for it to verify.

Thanks Tim & Christian and Beatrix for your help!

p.s. I’m wondering if this is a wide-spread issue with the latest security update?

I’ve waited and waited even with the betas
Finally copied to the desktop and they still ended up quarantined

Maybe Xojo could show a message and point people to a documentation page.

Let’s collect the idea in feedback: feedback://showreport?report_id=58591

Drag & Drop? Copy paste? I vaguely remember some issue here where macOS would quarantine in some cases depending how you moved the files. It also may be the destination folder that matters. Super frustrating, eh?

drag & dropped it to the desktop

I’ve done this so often I can just open terminal and run the cmd from my history :slight_smile:

!495 ; !496

done