Developer ID Application and Installer 'Not found'

I have almost succeeded in fixing my Apple Certificates to place my macOS and iOS app into the Apple AppStore! But I am having a final issue with my Developer ID Application and Developer ID Installer certificates.

This is what AppWrapper currently looks like:

AppWrapper offers to download these Developer ID’s via a button. I have downloaded all ten of my Developer ID Application and Developer ID Installer certificates, and added them to my Keychain, but they still show as Not Found in AppWrapper.

I have used Xcode to create the Developer and Distribution certificates, and these are showing OK on Apple’s Developer web site:

I have created and downloaded many AppStore Private Keys in the past ten years, and have them all stored in my Keychain. I have created many Profiles over the same time and have them installed inside my System Preferences.

FWIW, I also have the Apple Worldwide and Developer ID Certificate Authorities installed OK:

So what can I do to get AppWrapper/Apple to find my Developer ID Application and Developer ID Installer certificates?

I tried to remove/revoke my Developer ID Application and Developer ID Installer certificates, but you cannot. I contacted Apple Development and, after a request to delete my Developer ID Application and Developer ID Installer certificates, they replied:

"It has come to my understanding that you wish to to delete or revoke Developer ID certificates for housekeeping purposes.

Unfortunately, we can’t revoke Developer ID certificates, but please keep in that:
• You can link multiple applications to a single certificate.
• It’s important to back up private keys to prevent certificate access loss."

and (thinking I must be missing a Private Key):

" You mentioned in your message that you would like to know where to download a copy of your Private Key.

If you didn’t back up your private key, you need to create a new private key and then revoke all current certificates. After you’ve completed these steps, you can issue new certificates for development and distribution.

For information on how to create a private key and new certificates, please reference the Create, export, and delete signing certificates section of Xcode Help.

Revoking development or distribution certificates does not affect applications that are already available on the App Store.

You can continue to submit application updates to the App Store with a new distribution certificate. When your development certificate expires, your application will no longer run on your device. Additionally, applications distributed via ad hoc distribution will stop running after your distribution certificate expires."

I tried to create a new Private Key (via Keychain, as per AppWrapper Help) and used this to create new Profiles and, while this works, it doesn’t solve the issue of the Developer ID Application and Developer ID Installer certificates being ‘Not found’.

Any clues please on what I should try next?

You say, that you’ve downloaded them to your computer. Have you installed them by double clicking them?

Can you open Keychain Access and use the search field for “Developer ID”, if keychain sees them check the “Keychain” they’re on. Sometimes certificates get installed into the “System” keychain, and while I have yet to figure out the pattern, on some Macs, App Wrapper is prohibited from seeing anything in the “System” keychain.

If that’s the case, you’ll need to remove them from Keychain Access. Switch to the “Login” keychain (in the sidebar) and then drag the certs into the window, so they go where they should to start with.

@Sam_Rowlands Thanks for your advice. I have definitely downloaded all ten of them and tried both double-clicking the Developer ID Application and Developer ID Installer certificates and, deleting then dragging them into the Keychain’s login window.

Yes, they all appear to be installed into login, not System (also there is one in System Roots that I cannot delete):

All my AppStore Public Keys are installed into the login Keychain:

But AppWrapper is showing the Private Keys are missing (on every Developer certificate) and warning of duplicates:

What is my next step?

Oh man, the keys business is a black box and there’s no assured way I know of how to get them back when they’re gone. Sometimes simply re-downloading the certificate will bring it back, sometimes using Xcode brings it back and sometimes neither will bring 'em back.

Neither of those screenshots shows “Developer ID” private keys, when viewing certificates, it indicates private keys by having a disclosure triangle next to the certificate.

It is incredibly frustrating when an OS update wipes out the private keys.

Do you have a time machine backup or another Mac with fully operational keys. If you have another Mac, you can export the certificates from Keychain Access on that Mac and it will include the keys.

If you have access to another machine find the certificate in Login and expand out the private key.
Screen Shot 2022-09-28 at 8.40.20 PM
Export that as a p12 file, adding a password, transfer to new machine and install. Should work after that.

If you do not have access to another machine you should be able to download again from the Apple Dev Site for the ACCOUNT HOLDER that created the certificate in the first place. If that is someone else ask them to download and install into keychain, then do the above process sending you the p12 file.

I just moved development to a new machine and had to do all of this as well. The system / login issue held me up for a long time.