Desktop trial won't run

2019 r1 - Windows 10, 16GB’s RAM

I’ve been experimenting with the trial version. So far the web stuff runs, no problem.

Now I’m trying to follow the very simple stuff in the “Introduction to Programming with Xojo”. The desktop app is not running. Some of the sample desktops worked fine the other day. Today when I was doing the web stuff I had opened a 2nd instance of XoJo and tried to run that one. It wouldn’t work (discovered this a few days ago). So i shut down the 2nd instance. Web stuff still worked on instance 1. Shut Xojo down completely and she still won’t go for desktop. I don’t want to get in to the practice of having to reboot my machine every time Xojo hiccups.

What gives?

See image…

I can still run other sample desktop projects no problemo. Just not the very simple demo I built following the tutorial.

What does this mean? You click on Run and then … ??

It compiles and then nothing.

Hmm, works for me (2019R1 macOS). I click run, up comes the window, I enter data (or not) click the button and up comes the msgbox with the expected content.

OK, so I made a copy of the project, deleted all the controls and just left the window and still no-go. Then I created a new project, copied the controls from the original, and viola, she runs. Go figure.

On the left Nav, click App. Then open the inspector and see the section under Appearance. The DefaultWindow drop down should be set to the name of a window you wish to show on startup, in the screenshot you posted above the entry should read Window1. If this is set to None, nothing will be shows then the app starts and it will exit (in a simple app) as you’re expected to open a window in code rather than the framework opening the default on for you.

I assume this is what is happening, could you let us know if that’s the case?

So you open a project from that archive. Can you name it ?

Did you made any change to it ?

I assume you are talking about version 3 of the book (the one available here .

Julian, I can’t check since i moved on (deleted the non-functioning project). But thank you for the tip. I suppose that it’s possible that somehow that setting was set to none. In any case, good to know.

Emily, yes 3rd Edition, No sample project. I created it form scratch following the steps in the tutorial.


The projects are in the book archive (I checked the link before sharing it, read above).


You’re right. I do have them on my machine. Thanks

Nice !

Do not forget to tell us everything is OK (once it will be).

Of course, I want to build them by myself so I learn what’s going on. But good to know they are there if I have a problem

Wayne Golding has the answer in this thread:

Make sure that you have saved the project when this happens and that the debug location is either blank or is a valid path.