Deployment Errors/Issues

I have a very simple example (“Hello World”) of an Aloe Express app that works when run from the IDE, but when deploying to Xojo Cloud, it builds and uploads and the launching progress indicator closes, but then I get the “There was an error. Try again in a few minutes.” message after a few seconds. This has happened for as many times as I have tried to deploy it. Checking the Cloud Apps list under my account on, the app is listed there. Checking the server with my SFTP client shows that it is not there.

I have successfully deployed other apps to the same sever. BUT, I tried to delete one of them using the control panel and it says it was deleted (i.e. - no longer shows in the app list there), but it is still there on the server when I check with the SFTP client.

Any ideas?

Happens to me all the time that message.

We’re working on a check with @Jason Parsley to see how we can get Aloe to work too (using the cgi middleman.

Hi Cliff - can you please email me ( that very simple app that will not deploy?

I might have a fix for the Aloe / Xojo Cloud issue.

If you guys continue to run into issues, let me know.

Just did - thanks!

FWIW - I was able to deploy a slightly more complex AloeExpress based XC app before it tried the simple one. It didn’t work, but it would deploy.

That would be fantastic, since I really would like to use Aloe on Xojo Cloud.

The test app that Cliff sent to me will deploy but it appears to get stuck when trying to launch.

it doesn’t seem to deploy on my XC server. I can’t see it’s directory with the SFTP client. I should be able to see it, right?

It’s directory should show up. I see it when I list apps and I can delete it from the list.

i see it in the app list too, but then i go check the server and the directory is not there.

For my more complex AE based app, even when I delete that app from the app list, the directory remains on the server. I can’t even delete it using the SFTP client.

Ignore my last few posts - my SFTP client doesn’t refresh the remote directory very well. The app list and the server directories DO match.