Deploying Web 2.0 app

Anyone had success deploying to a VPS?

I have built specifying port 9000 in the build, opened that port in my firewall.

I get the “Application is ready” message when I run the app but I get "Failed, cannot connect to the server when I put :9000 on the end of my domain to run it.

If I run # netstat -plunt | grep “9000” I get :

tcp 0 0* LISTEN 8669/./test

Have you allowed through your VPS firewalld/iptables? I’m running the GraffitiSuite Web 2.0 demo on a 64-bit CentOS7 VPS without issue.

Also, make sure the exec bit is set and you have libsoup and libunwind installed depending on which OS you chose.

Yes, see my second section of the second line of my post.

As I said in my original post it is running as I get the “application is running” message

Just providing the steps for double-checking. If you’ve applied the firewall rules and done the rest, can’t help you. Sorry. :frowning:

What OS?

CentOS Linux release 7.8.2003 (Core)

That’s the same version I’m running. It really sounds like the port is still blocked.

I can telnet to it and if I try nc -zvw10 9000 I get :
nc: connectx to port 9000 [tcp/ssh] succeeded!

This is from home to a VPS so it can connect therefore it’s not being blocked.

Have you checked the system logs to see if the app is hitting an error on connection? Barring that, I have no idea.

Please run the netstat command without your app running to make sure there’s not another app bound to that port.