Deploy on vps, getting error 500


On my VPS I’m getting an error 500 after running my new second Xojo cgi app.
The server is configured for Xojo CGI scripts and an other xojo app is running perfect for about 18 months.

The most strange thing is that compiling with 2014R3 works. Using the most recent version it doesn’t work.
In an other conversation they told me an internal error 500, must be searched in the webapp code and showing error messages would help.

This is what i have done:

I compiled my webtest project in Xojo 2015r2.2 version.
Set as Linux, 32Bit (also tried with 64bit), automatic port number
added messagebox in the two unhandelderrorexeptions.

Then I uploaded the files to my cgi-bin folder on my VPS.
I have two subfolders.
In one of them I have my working cgi app (compiled in 2014R3)
The other folder is created for the new cgi app.

Foldername “webtest” --> 755

In that folder I copied in BINARY mode the next files:

  • webtest (no extention) --> 755
  • webtest.cgi --> 755
  • --> 755
  • folder “webtest Libs” --> 755
  • in “webtest Libs” all the libs so files. --> 755

and in ASCII mode the next files:

  • config.cfg --> 644
  • .htaccess (no changes) --> 644
  • folder “webtest Resources” --> 644
  • in “webtest Resources” all the resource folders and files --> 644

And then i get the internal error 500[/quote]

Can anybody help me?

Have you check the error Log file for error?
Check maybe the php for timeout error
for cgi most is

[quote]Files - 644
CGI Scripts - 755
Directories - 755[/quote]

Double check that your server meets the system requirements for Xojo 2105r2.2 web apps.
I recall the minimum library versions changed somewhere along the way between 2014 and 2015.

Could it be the lack of Libicu installed on your system. It has been required since 2015R1, I think.

@ Michel indeed Libicu points me to the solution.
I found this info after searching on Libicu[quote][/quote]

I updated / installed the libicu library by SSH on my CentOS vps

yum install libicu.i686

and I entered the update command

yum update

Now it works! Thanks a lot!