Deploy not working on development PC

I have a problem with Deploy getting to 0:00 remaining then stopping.

This only seems to happen on the computer on which the app was being developed (Win 7 Pro 64-bit). It does not happen on two other computers I have tried.

The only clue I can give is that this problem seems to coincide with taking out CopyFiles1 in build steps. I only added it temporarily to get files uploaded.

Is there some way to “reset” the Deploy. I have tried deleting cache, deleting build folder, deleting app from Xojo Cloud server, restarting the server. Nothing works.

Try changing the Application Identifier. I’ve run into a similar problem recently and changing the Application Identifier resolved it. After a few days of not using the Xojo Cloud, I was able to change the Application Identifier back to the original value.

Were you able to exit the IDE normally? My experience with a similar problem led to another and that was having to Force Quit on OS X to quit the IDE.


Tried looking at your case number but says it couldn’t be found (might be private).

I tried renaming Application name under build settings. Still no go.

Tried uninstalling then reinstalling Xojo. Still no go.

Tried renaming the app as well as the application name in build. Still no go.

Another possible clue: I saw this same behavior when I had dragged and dropped a jpg into the project. I thought I got these all out but maybe there is still one in the project. Unfortunately, I can’t find any. So, I guess what I have to do is copy modules one by one into a new project. Damn.

Try changing the app identifier. We had some reports right before the conference where adding a 2 to the end of the identifier was a good temp fix.

Ok. I did try rename as per Frederick’s suggestion (didn’t seem to work) but I will try your suggestion tomorrow.

Let me know if you can’t track this issue down. I think I might be able to work up a demo that replicates the problem. I think it has something to do with either dragging images into the project (then deleting the image) and/or using the copy files in build step (then deleting this step).

Need to change app identifier under shared, right? app name under build? both?

Is there any way to reset the server (other than restart which I have tried)?

I have been avoiding using the delete button. Let me know if that’s something I should try. I will assume not.

Seems like something wrong on the PC though because it seems to work fine on other PCs.

Greg - that worked but it also worked when I switched back to original app name and app id (without added 2). I created a case that occurred when I was changing names back to original names (feedback case #32942). Please let me know if I can do anything to help you pin this down.