Deleting Events Causes Xojo Crash

I’ve encountered a problem with Xojo crashing when I attempt to delete an event that I assigned to an object. Although it’s happened several times now with different events on different objects, it doesn’t happen consistently with all objects and events. I’m using Windows 7 Ultimate 64 bit OS. The event can have content or no content and it doesn’t make a difference … when I right click on the event in the Project Window (or Project Hierarchy as it now is with Xojo) on the left of the interface and choose “Delete” from the context menu, Xojo immediately crashes with the fatal exception error message. Also, although I haven’t tried every combination, it seems to occur always with Container Control instances (e.g., ‘Open’ event).

I’ve searched the forum and can’t find another similar report. And before someone suggests I file a Feedback bug report, that’s still another issue … I still have been unable to get Feedback to work on my system (it identifies me as a “Trial” user and won’t enable the Submit button) … which I reported in an earlier thread where I ran into another issue using Container Controls.

My immediate quandary right now is how to get rid of the unwanted event … any ideas? Anybody else seeing this behavior?

I always save what i have done before i do something that i know will trigger a crash (usually cut and paste a form from one project to another)

I’m having the same issue. I have added an event handler ConstructContextualMenu to my container control on a window. I now want to delete the event handler and every time I try I get fatal exception and Xojo shuts down…

I have not observed this, but I haven’t tried Win 7 x64. I’ll get that OS set up to test. In the meantime, you can just remove the code to effectively prevent the event from doing anything.

Ensure that you are logged in using the correct username and then check with customer service. Perhaps something on your account is not configured properly.

Paul, I am not on Windows I am on MacOs 10.8.4. Yes I can delete the code.

Testing on Windows 7x64, I am able to reproduce this bug reliably.

  1. Create a new project and add a new ContainerControl to Window1
  2. Add an event (any) to the container on Window1 and put some code in it.
  3. Save the project in text or XML format. Binary format appears unaffected.
  4. Attempt to delete the event

feedback://showreport?report_id=27703

Yep, had already done that but was trying to clean up the residual artifacts (my wife always tells me to pick up after myself :-))
Actually, found that although I can’t delete the container control events without the crash, I can delete the actual parent container instances (super class) themselves without a crash. Just ended up doing that and replacing them as a workaround.

Have done that over and over again … to no avail. Even tried it on a separate laptop computer in my office here … still shows me as “Trial”. Reported this to Geoff in an earlier thread (another issue I posted) and he said he was going to look into the Windows 7 64-bit aspect with someone else (forgot the name he used now) as a possibility. Haven’t heard or seen a thing since. Even tried uninstalling and reinstalling Feedback yet one more time today … “lights are on, gates are down … train ain’t coming”

This is a frustrating bug especially when you forget and casually delete something - BANG. One more complication is that if you delete a defined event within a class that has already been implemented in another class - then you will get a compilation error. The frustration is that it is not possible to delete the event in the other class without crashing Xojo. The only solution I’ve found is to re-create the previously deleted defined event in the original class and to leave it empty doing nothing.